fail to get clover report

I cannot find the solution in https://answers.atlassian.com/questions/45196/getting-streamjava-io-eofexception-when-creating-the-merging-databases-to-generate-clover-report

So what can i do?

This is my log

clover.report:
[clover-html-report] Clover Version 3.1.8, built on November 13 2012 (build-876)
[clover-html-report] Loading coverage database from: 'xx/.clover/clover3_1_8.db'
[clover-html-report] Failed to load coverage recording RecordingTranscripts.FileRef[datafile=/xx/.clover/clover3_1_8.db6ae5ye_he9co7u5, testRecording=false, typedTestId=-1, runId=0, hash=380254118, timestamp=1363231223213]
[clover-html-report] java.io.IOException: java.io.EOFExceptionjava.io.IOException: java.io.EOFException
[clover-html-report] 	at com.cenqua.clover.RecordingTranscripts.readCoverageFromDisk(RecordingTranscripts.java:107)
[clover-html-report] 	at com.cenqua.clover.RecordingTranscripts$FileRef.read(RecordingTranscripts.java:356)
[clover-html-report] 	at com.cenqua.clover.CoverageDataCollator.collateRecordingFiles(CoverageDataCollator.java:117)
[clover-html-report] 	at com.cenqua.clover.CoverageDataCollator.loadCoverageData(CoverageDataCollator.java:67)
[clover-html-report] 	at com.cenqua.clover.CloverDatabase.loadCoverageData(CloverDatabase.java:165)
[clover-html-report] 	at com.cenqua.clover.CloverDatabase.loadCoverageData(CloverDatabase.java:160)
[clover-html-report] 	at com.cenqua.clover.reporters.CloverReportConfig.getCoverageDatabase(CloverReportConfig.java:341)
[clover-html-report] 	at com.cenqua.clover.reporters.Current.getCoverageDatabase(Current.java:123)
[clover-html-report] 	at com.cenqua.clover.reporters.CloverReporter.<init>(CloverReporter.java:33)
[clover-html-report] 	at com.cenqua.clover.reporters.html.HtmlReporter.<init>(HtmlReporter.java:126)
[clover-html-report] 	at com.cenqua.clover.reporters.CloverReporter.buildReporter(CloverReporter.java:72)
[clover-html-report] 	at com.cenqua.clover.tasks.CloverReportTask.generateReports(CloverReportTask.java:427)
[clover-html-report] 	at com.cenqua.clover.tasks.CloverReportTask.cloverExecute(CloverReportTask.java:384)
[clover-html-report] 	at com.cenqua.clover.tasks.CloverHtmlReportTask.cloverExecute(CloverHtmlReportTask.java:108)
[clover-html-report] 	at com.cenqua.clover.tasks.AbstractCloverTask.execute(AbstractCloverTask.java:55)
[clover-html-report] 	at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
[clover-html-report] 	at sun.reflect.GeneratedMethodAccessor1.invoke(Unknown Source)
[clover-html-report] 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[clover-html-report] 	at java.lang.reflect.Method.invoke(Method.java:592)
[clover-html-report] 	at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
[clover-html-report] 	at org.apache.tools.ant.Task.perform(Task.java:348)
[clover-html-report] 	at org.apache.tools.ant.Target.execute(Target.java:357)
[clover-html-report] 	at org.apache.tools.ant.Target.performTasks(Target.java:385)
[clover-html-report] 	at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
[clover-html-report] 	at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
[clover-html-report] 	at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
[clover-html-report] 	at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
[clover-html-report] 	at org.apache.tools.ant.Main.runBuild(Main.java:758)
[clover-html-report] 	at org.apache.tools.ant.Main.startAnt(Main.java:217)
[clover-html-report] 	at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
[clover-html-report] 	at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
[clover-html-report] No coverage recordings found. No report will be generated.

5 answers

This widget could not be displayed.

What version of operating system and java do you have?

What flush policy was used for code instrumentation? Do you have any 'clover.db*.1' files?

This widget could not be displayed.

a Virtual Machine about redhat 4

jdk1.5.0_22 or jdk1.6.0_35 has the same error

The flush policy is directed.

some "clover3_1_8.db18c1kl9vnk2rh_ze_6ae5ye_he9dl0ex.s" files

but the file "clover3_1_8.db6ae5ye_he9co7u5" is nothing on it

export ANT_OPTS="-Xms256m -Xmx2048m"

two weeks ago,the build.xml is run ok ,but now fail.

another computer about windows7 run the build.xml is also ok

This widget could not be displayed.

a Virtual Machine about linux redhat 4

jdk1.5.0_22 or jdk1.6.0_35 has the same error.

The flush policy is directed.

files :"clover3_1_8.db1*.s" "clover3_1_8.db" "clover3_1_8.db6ae5ye_he9co7u5"

The file "clover3_1_8.db6ae5ye_he9co7u5" is empty.

ant:apache-ant-1.7.1

export ANT_OPTS="-Xms256m -Xmx2048m"

Two weeks ago,the build.xml is run ok ,but now fail.

This widget could not be displayed.

Could you please create a support ticket at support.atlassian.com (under the "Clover Support" project)? I'd love to help you troubleshoot the problem, but I will need some log files and build files.

This widget could not be displayed.

Thank you very much.

I change the build.xml to solve this problem.

<target name="with.clover" description="start clover">

<!--<clover-setup/>-->

<clover-setup flushpolicy="interval" flushinterval="5000"/>

</target>

It may be somethings wrong with the default flush policy.

I see "In the most common unit testing scenarios, the default flush policy will suffice." in https://confluence.atlassian.com/pages/viewpage.action?pageId=72253499

So I use the default flush policy in my unit testing scenarios.

When I change it to interval, I can get clover report.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published 56m ago in Bitbucket

Branch Management with Bitbucket

As a project manager, I have discovered that different developers want to bring their previous branching method with them when they join the team. Some developers are used to performing individual wo...

15 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you