Upgrade to 3.1.10.v20130108000000 (build-885) breaks IntelliJ Idea plug-in

After most recent update (prompted with pop-up window) of Clover plugin in my IntelliJ Idea (ver 11.1.5) it become unavailable for use in any of my projects. It should ask me whether I want to make upgrade and post clear and noticeable message that this update will disable Clover plugin when license date is earlier than the build date or should not allow upgrade at all. I cannot be forced to buy a new upgrade if I am satisfied with existing version of Clover plugin.

Thank you

1 answer

0 votes

Our software licenses entitle you to perpetual use, and include 12 months maintenance (updates/support) commencing from the date of purchase. It means that you cannot use Clover version which release date is later than the end of maintenance date for your license.

Indeed, a Clover upgrade dialog box in IntelliJ IDEA checks only if new version is available and it does not perform validation whether this new version still fits into your maintenance period.

I will add proper warning for this - see CLOV-1208.

Cheers
Marek

Suggest an answer

Log in or Sign up to answer
Community showcase
Asked Thursday in Jira Ops

I'm John Allspaw, Ask Me Anything about incident analysis and postmortems

I'm John Allspaw, co-founder of   Adaptive Capacity Labs, where we help teams use their incidents to learn and improve. We bring research-driven methods and approaches to drive effective inciden...

5,414 views 21 17
View question

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you