Ignoring methods in Clover with Eclipse

I'm using Clover with eclipse and I set up a rule to ignore certain methods. In the class it shows the methods greyed out and says they are excluded, however I see that it is still counting that method towards coverage % and showing that method as all red instead of greyed out. How do I get Clover to stop including the method in the coverage % number?

2 answers

1 accepted

Accepted Answer
1 vote

I have created a CLOV-1108 bug report for this.

As a workaround you can use HTML report - it shows filtered-out methods correctly. Alternatively, you could use ///CLOVER:OFF + ///CLOVER:ON comments to disable certain code blocks from instrumentation.

Thanks for fixing!

Thanks for fixing!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published 9 hours ago in Jira Ops

Jira Ops Early Access Program Update #2: Let’s talk severity levels

Welcome to your weekly Jira Ops Early access program update, where we’re sharing news and updates on Jira Ops' progress as we work toward our 1.0 release. If you ever want to drop us feedback or idea...

20 views 0 0
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you