How to display Clover output through Bamboo

I am trying to integrate code coverage via Clover into my Bamboo plans. The ant script already generates the XML report (via <clover-report>) and generates the file clover/clover.xml. In terms of configuration, I have selected the "Clover is already integrated..." bullet, as well as specified the Clover XML location at "clover/clover.xml"

I have also created an artifact using the same location. When I run the plan, an look under the cooresponding Clover tab, all that is there is, "This XML file does not appear to have any style information associated with it. The document tree is shown below." followed by the tree of course.

Did I miss some configuration?

Bamboo 3.1

Clover 3.1


Thank you.

1 answer

1 accepted

0 votes
Accepted answer

Bad configuration.

Artifact Location: clover

Artifact copy: pattern **/*.*

clover xml location: clover/**/clover.xml

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Jan 15, 2019 in Statuspage

Introducing Statuspage Getting Started guides! First up: What is Statuspage?

Over the next several weeks we'll be sharing some of our Getting Started guides here in the community. Throughout this series of posts, we'd love to hear from customers and non-customers ab...

299 views 5 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you