Corrupted Clover-for-Ant 4.0.3 (zip64 extended information error)

Running a build with clover.jar from Clover-for-Ant 4.0.3 fails with an error like this:

BUILD FAILED

c:\clover-ant-4.0.3\tutorial\build_completed.xml:19: The following error occurred while executing this line:

Error reading project file jar:file:/c:/clover-ant-4.0.3/lib/clover.jar!/cloverlib.xml: central directory zip64 extended information extra field's length doesn't match central directory data.  Expected length 0 but is 16

This error does not happen with Clover 4.0.2 or older. Does it mean that Clover 4.0.3 JAR is corrupted?

1 answer

1 accepted

0 votes
Accepted answer

Clover 4.0.3 JAR is not corrupted. Ant contains a bug related with implementation of ZIP64 extended information field. This error occurs in Ant 1.9.0/1.9.1 and has been fixed in Ant 1.9.2

Solution: use Ant 1.9.2 or later.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Dec 10, 2018 in Confluence

Organizing your space just got easier - Page Tree Drag & Drop is here

Hi Community! I’m Elaine, Confluence Product Manager. You may have read my earlier post about page tree in space navigation sidebar. I'm excited to share another improvement that helps you organize ...

196 views 5 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you