Clover-Historypoint target error

Hi all,

when I am executing clover  historypoint target it gave me error like this 

home/IdeaProjects/WebApp/build.xml:301: com.atlassian.clover.registry.NoSuchRegistryException: Clover registry file "/home/IdeaProjects/WebApp/.clover/clover4_1_1.db" does not exist, cannot be read or is a directory.
Please ensure Clover has instrumented your source files. My report target as follow

 

<target name="clover.report" >

<clover-report initstring="/home/Desktop/Clover/.clover/clover4_1_1.db">


<current outfile="/home/tomcat/webapps/common/pages/Clover-report" title=" Code Coverage Report">
<format type="html"/>
<fileset dir="src/server"/>
</current>

<historical outfile="/home/tomcat/webapps/common/pages/historical-report" title="Historical Report" historyDir="/home/Desktop/Clover/historypoints">
<format type="html"/>
</historical>

</clover-report>

 
<clover-historypoint historyDir="/home/Desktop/Clover/historypoints" overwrite="true">
<fileset dir="src/server"/>
</clover-historypoint>
</target>


Why this error come? in most cases, most people told about instrument or clover db file problem
 But my case report is generated, but they could not run <clover-historypoint> target. Build failed because of this target execution fail. So I can't generate historical report, only generate current report and build failed. How do I over come this problem?

2 answers

1 accepted

1 vote

Hello Dulsara,

As you can see, the clover-historypoint task is looking for a database file in:

/home/IdeaProjects/WebApp/.clover/clover4_1_1.db

and in clover-report you use:

/home/Desktop/Clover/.clover/clover4_1_1.db

You have to use:

&lt;clover-historypoint initstring="/home/Desktop/Clover/.clover/clover4_1_1.db" historyDir="/home/Desktop/Clover/historypoints" overwrite="true"&gt;

Alternatively, you can call clover-setup task before, as described here:

https://confluence.atlassian.com/display/CLOVER/clover-historypoint

Cheers
Marek 

Thank you very much, It works fine

2 votes

Hello,

 I think it's connected with the fact you're not passing the initstring parameter to clover-historypoint.  According to the message it looks for the DB in a default location. 

Just try to modify it in somewhat in this way:

&lt;clover-historypoint historyDir="/home/Desktop/Clover/historypoints" overwrite="true"  initstring="/home/Desktop/Clover/.clover/clover4_1_1.db"&gt;
&lt;fileset dir="src/server"/&gt;
&lt;/clover-historypoint&gt;
&lt;/target&gt;
Thank you very much, it works properly.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published yesterday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

72 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you