It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

xUnit with WebHostBuilder and POST Method

Michael Oct 23, 2017

I have a unit test that uses WebHostBuilder to simulate an HTTP POST method against a .NET Core 2.0 WebAPI controller.  The test works and passes when I execute in Visual Studio but it does not pass in Pipelines.

I also use WebHostBuilder and HttpClient for a GET request and that passes in both VS and Pipelines.  Any suggestion as to why is appreciated.

Note this is a Docker project and the test image I am using in Pipelines is microsoft/aspnetcore-build:1.0-2.0.  I am unclear if that affects anything or not.

0 answers

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Bitbucket Pipelines

Building a Bitbucket Pipe as a casual coder

...ipe.sh :  #!/bin/bash source "$(dirname "$0")/common.sh" enable_debug extra_args="" if [[ "${DEBUG}" == "true" ]]; then extra_args="--verbose" fi # mandatory variables R...

3,135 views 1 22
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you