subversion: ERROR: unable to determine version

Hello experts

I am trying to migrate our svn repository to git using the directions from https://www.atlassian.com/de/git/migration

When I run the command to verify the prerequisites, I get the error

subversion: ERROR: unable to determine version

I am running the command on the subversion server, svn is installed and gets the following output in commandline:

>svn --version
svn, Version 1.7.4-SlikSvn-1.7.4-WIN32 (SlikSvn/1.7.4) WIN32
übersetzt Mar 8 2012, 13:26:42

 

Can you help me fixing this problem?

 

Thanks a lot & best regards 

 

Daniel

7 answers

1 accepted

3 votes

It looks like the migration script tries to check the version of the svn binary, but due to it not being in the expected format, it fails.

Can you try using a non-translated or English version of Subversion? Depending on how the translations are done, doing this before running the commands may help:

export LANG=C

After that, check if the output of svn --version changes.

svn --version  works however,

C:\Users\XiaoR>java -jar C:/Users/XiaoR/Downloads/svn-migration-scripts.jar verify
svn-migration-scripts: using version 0.1.56bbc7f
Git: ERROR: Unable to determine version.
Subversion: using version 1.7.8

 

Are you running this?

java -jar svn-migration-scripts.jar verify

Thanks a lot Robin!

I did the equivalent command

SET LANG=C

in Windows. Now verification works (and I can go to the next step)

Best regards, Daniel

Yes exactly!

Thank you, Daniel 

0 vote

Are you running the verify command on that server? For the migration to work the client needs to have an svn client available.

Hi Stefan Yes, I am running the verify command on the server which is running svnserve as a windows service. If I run the "svn --version" command I get the output mentioned above, I guess this means that the svn client is installed correctly? Thanks, Daniel

Hello guys,

I am getting similar error (in bold) when I run verify command:

>java -jar svn-migration-scripts.jar verify

svn-migration-scripts: using version 0.1.56bbc7f
Git: using version 2.5.3.windows.1
Subversion: ERROR: Unable to determine version.
git-svn: using version 2.5.3.windows.1

I have Tortoise-SVN installed on my windows machine. And I think the same error is causing next command to fail:

>java -jar svn-migration-scripts.jar authors <svn_repo> > authors.txt

About to create the authors file.
Exception in thread "main" java.io.IOException: Cannot run program "svn": Create Process error=2, The system cannot find the file specified

at java.lang.ProcessBuilder.start(Unknown Source)


Can someone please help me out here. What I am doing wrong or missing anything?

I did also try, SET LANG=C, but no luck sad

I had this same issue.

You need to run the Tortoise-SVN installer again and modify the current installation. This will allow you to install the command line tools.

Once you have the command line tools installed you will be able to run svn -- version and the migration scripts.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jun 12, 2018 in Bitbucket

Do you use any Atlassian products for your personal projects?

After spinning my wheels trying to get organized enough to write a book for National Novel Writing Month (NaNoWriMo) I took my affinity for Atlassian products from my work life and decided to tr...

23,453 views 26 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you