It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

submodules work on sourceTree when pulling from github, not bitbucket

abdullah bakhach Dec 12, 2012

this is driving me crazy..

so this is a git repo hosted on github that if pulled onto sourceTree, the submodules work like a charm:

https://github.com/abbood/remailPOP3

however an exact copy of that repo on bitbucket

https://bitbucket.org/abakhach/breeze

doesn't seem to be able to show the submodules in source tree.. the settings are all the same! (ie in both .gitmodules and .git/confing) any ideas?

1 answer

1 accepted

0 votes
Answer accepted
Steve Streeting Dec 12, 2012

The .gitmodules file on the bitbucket repo refer to a dead link:

https://abakhach@bitbucket.org/abakhach/mailcore.git

It looks to me like you moved the parent repo to Bitbucket but not the submodule repo, but you changed the submodule URL anyway, leading to a 404. You'll need to import your mailcore project into BB at that URL to resolve this.

abdullah bakhach Dec 12, 2012

i actually tried what you suggested earlier (see here, and i already have the mailcore repo hosted on BB ) but it still didn't work..

i think it may have to do with a case mismatch.. when i clone the repo it's called 'MailCore' but bitbucket makes it all lowercase.. i'm working on it..

abdullah bakhach Dec 12, 2012

i think i know what it is.. if i click on hosted repositories.. all my github repos show up fine.. but for some reason i can't access my bitbucket one.. if i add a bitbucket repo i get the dreaded 'bitbucket api call failed'.. i had the same problem when i was adding my github account.. but then updateding to the latest sourceTree version (1.5.6) solved the problem..

Steve Streeting Dec 16, 2012

That error is usually a login issue, often it's something simple like case sensitivity on the user name.

I just tried to clone your repo again and the MailCore part worked fine, it couldn't get three20 though because I don't have access. So is this solved?

abdullah bakhach Dec 17, 2012

yes it is.. sorry for the late reply

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Bitbucket Pipelines

Building a Bitbucket Pipe as a casual coder

...ipe.sh :  #!/bin/bash source "$(dirname "$0")/common.sh" enable_debug extra_args="" if [[ "${DEBUG}" == "true" ]]; then extra_args="--verbose" fi # mandatory variables R...

3,067 views 1 20
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you