"NotFound" authenticating from Sourcetree 2 to Bitbucket Server and LDAP (Active Directory) Edited

Greetings - 

I'm trying to login to a current Bitbucket Server (maybe one minor rev behind) with the latest version of Sourcetree (2.1.11.0) and having no luck. The Bitbucket server is LDAP integrated with Active Directory and access with a browser, the git CL and Visual Studio all work great.

I've been able to connect Sourcetree to the Bitbucket Server with the admin account from the Bitbucket Internal Directory, so I'm fairly confident there aren't any networking issue (proxies, TLS, etc). 

 

It's only when I try with an LDAP account do I receive this "NotFound" and "User xyz does not exist." error. 

NotFound.png

Any suggestions? 

Thx!
Bryan

 

1 answer

0 votes

Hi,
Can I ask if you are using email addresses for the username? SourceTree expects to use the username set in Bitbucket Server, in https://stash.atlassian.com/profile,  rather than an email address used as identity by external systems

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

885 views 5 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you