pre-receive hook declined issue

Hi ,

We have on-prem bitbucket server which was working untill now. 

I am unable to push the code anymore to the repo as its throwing hook decline error.

I checked the hooks are disabled and verified the permissions at global /repo and branch and added the user manually but no luck also tried creating new branch and push but still did not work.

I am using windows GIT bash and BitBucket server is hosted on windows 2008 server

$ git push origin test
Counting objects: 6, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (4/4), done.
Writing objects: 100% (6/6), 525 bytes | 0 bytes/s, done.
Total 6 (delta 2), reused 0 (delta 0)
To http://<servername>/scm/sdms/helloteamcity.git
! [remote rejected] test -> test (pre-receive hook declined)
error: failed to push some refs to 'http://<username>@<server name>/scm/sdms/helloteamcity.git'

1 answer

0 votes
Praveen K I'm New Here Sep 25, 2018

I'm also facing the same issue. Does anybody has solution for this.

@Vijay Dharman did it resolved for you?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

212 views 3 7
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you