Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,296,032
Community Members
 
Community Events
165
Community Groups

impossible to activate plugin "trainingssystem.v2"

Hey,

I´ve tried the whole day to activate the plugin from bitbucked named "trainingssystem.v2" and I always get the following error message:

 

Warning: require(/homepages/13/d877412181/htdocs/clickandbuilds/TranskulturelleKompetenz/wp-content/plugins/trainingssystem-plugin/plugin-update-checker/plugin-update-checker.php): failed to open stream: No such file or directory in /homepages/13/d877412181/htdocs/clickandbuilds/TranskulturelleKompetenz/wp-content/plugins/trainingssystem-plugin/trainingssystem-plugin.php on line 124

Fatal error: require(): Failed opening required '/homepages/13/d877412181/htdocs/clickandbuilds/TranskulturelleKompetenz/wp-content/plugins/trainingssystem-plugin/plugin-update-checker/plugin-update-checker.php' (include_path='/homepages/13/d877412181/htdocs/clickandbuilds/TranskulturelleKompetenz/wp-content/plugins/backwpup/vendor/pear/archive_tar:/homepages/13/d877412181/htdocs/clickandbuilds/TranskulturelleKompetenz/wp-content/plugins/backwpup/vendor/pear/console_getopt:/homepages/13/d877412181/htdocs/clickandbuilds/TranskulturelleKompetenz/wp-content/plugins/backwpup/vendor/pear/pear-core-minimal/src:/homepages/13/d877412181/htdocs/clickandbuilds/TranskulturelleKompetenz/wp-content/plugins/backwpup/vendor/pear/pear_exception:.:/usr/lib/php7.4') in /homepages/13/d877412181/htdocs/clickandbuilds/TranskulturelleKompetenz/wp-content/plugins/trainingssystem-plugin/trainingssystem-plugin.php on line 124

 

Could someone tell me what it means and how to solve this problem?

I would be really really thankful !

2 answers

0 votes
Daniel Ebers Community Leader Aug 06, 2021

This suggests the code is not able to open the data it was told by their developers to refer to.

From the path I can see it tries to contact a shared hosting file storage.

I would suggest contacting the administrator of your Bitbucket instance - they should be (hopefully at least) more familiar with the App installed.

From its name it is probably one unique to your installation  (does not sound familiar)

Regards,

Daniel

Hey Daniel,

Thank you for your kind answer. I will contact Bitbucket then.

Regards,

Helen

0 votes

Could you tell us where you're getting this app from and what docs you are following for installing it on Bitbucket?  (I can't find anything in the marketplace)

Sure:
It is from:

https://bitbucket.org/cosa1/trainingssystem.v2/downloads/

It is a .zip data, that I've uploaded. 

Right, so it's a random zip file.

What are you trying to do with it, and what docs are telling you how to install and use it?

The Training System is a Wordpress plugin for hosting a Wordpress-based training platform. Training units can be divided into trainings, lessons and pages.

I need this plugin to build the website and set up the training sessions.

 

The doc that tells me how to install it is on:

https://bitbucket.org/cosa1/trainingssystem.v2/wiki/Home

It´s in german but overall it tells:

The plugin can be easily installed via the WordPress backend and the menu item "Plugins->Install". After the ZIP file has been successfully uploaded via the button "Upload Plugin", it only needs to be activated. That this has worked can be seen by the fact that the menu item "Training System" has now been added in the WordPress backend.

Ah, I thought it might be this.

You've landed in the wrong place here.  You have clicked on "help with bitbucket" rather than "help with this thing that is being hosted on bitbucket".

We were a bit slow to spot this because Bitbucket does have a plugin (app) system and it may well have been a Bitbucket app you were trying to install.

But your clarification is that it's a Wordpress plugin tells us it is not.  I think you might want to ask in a Wordpress forum and try contacting the authors of the plugin (contact details should be somewhere in the bitbucket site)

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,174 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you