Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

hg push gives 502 Bad Gateway

When I try to do hg push, I get the error:

searching for changes
abort: HTTP Error 502: Bad Gateway

The commit I have is pretty big (hg says 150MB) but it only makes it through to 70MB progress when I get this error. I don't think this bumps me over the 1GB limit. I think I have had such big commits before and they were going through fine.

I have seen similar topics and it seems it has something to do on Attlassian end.

Please investigate.

2 answers

1 vote
Ana Retamal Atlassian Team Dec 11, 2018

Hi!

A 502 error means that either the server can't handle what you are doing, or the network you are on cannot carry it. Can you try pushing using a different network (work, home, library, etc) and let us know what happens? Does the push go through? Are you getting any error?

Best regards,

Ana

I tried making a new test repo and pushing to that, it works. The problematic repo in question still doesn't work.

I cannot try the same problematic push on a different network as I am on a desktop. However, bitbucket pushes have been working for years now with no issues and the network is perfectly stable (optics). 

I suspect the commit size is too big and rejected by the server. 

What can further be done about this issue?

I had a similar issue: I was trying to push thousands of commits and got a 502 error. I can only push like 100 revisions per push to make it work. 

Sadly, there is no clear way to adjust the postBuffer size with mercurial to solve your issue easily. 

Best, SC

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

326 views 2 10
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you