Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

git push stuck forever when running Bitbucket as a Docker image

Im running Bitbucket with Atlassians public docker images. Everything seems to be working until I tried to push a little bit bigger git repo. It is like 170 MB,

 

When i run the command

git push -v

 

It looks like it uploads all files in the commit but the get stuck on a line forever:

 

POST git-receive-pack

 

I have increased the Http.Postbuffer to a really big number.

 

Regards

/Dave

2 answers

Hello @davidselin

I can understand your frustration as this can be demotivating to your workflow and productivity. We as @ACNairobi we have curated a few suggestions that we think can be of help. 

  • Kindly check with your Bitbucket Admin/settings if the file limit is set below 170MB (Increase the size).
  • It would help to also check your internet bandwidth/speed.
  • Cross-check with docker to see if the problem is on the docker side.

Please let me know if any of the above resolutions resolve your problem.

Regards

MK

Hi @Michael Kimathi _AC Nairobi_ Kenya_ 

We run Bitbucket as on prem server, is there any limitations on size?

Regarding speed :

  *When I increased the http buffer the push command seemed to run quicker, but it get stuck on POST git-receive-pack. 

  * If SSH is used instead, it was back to super slow upload speed.

 

I have also increased memory on my docker desktop, what else should I check on docker side?

 

regard

DS

Hello @davidselin ,

Let me know if you followed this guide: https://hub.docker.com/r/atlassian/bitbucket-server/ in setting up the memory and relevant setup (Connection, size, and if you have updated bitbucket server especially if you are running on-prem server) to enable you to run and push without any setbacks.

On ssh please refer here and feel free to raise a support ticket so that Atlassian can replicate your build: 

https://jira.atlassian.com/browse/BCLOUD-19451?_ga=2.121742863.568156899.1588359416-1173176553.1588359416

Let me know if it works after following above steps.

 

Regards

MK

0 votes
Dave Chevell Atlassian Team May 03, 2020

Hey @davidselin,

A few quick questions:

 

  1. What version of Bitbucket Server are you running? e.g. 6.10.1, 7.0.1, etc. 
  2. How is Bitbucket configured at the HTTP layer? e.g. is it terminating SSL directly? Do you have a reverse proxy in front of it? 

I'm wondering whether you cold be running into BSERV-12285 (fixed in 7.1.1 and 7.2.0) but we'd need more information to confirm.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,717 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you