Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

can't open '$BITBUCKET_PIPE_SHARED_STORAGE_DIR/aws-lamda-deploy-env': No Such file or directory

Running pipe aws-lambda-deploy  shows writing result to the $BITBUCKET_PIPE_SHARED_STORAGE_DIR/aws-lamda-deploy-env but when I try to Open it shows no file/ Directory

2 answers

1 accepted

0 votes
Answer accepted

I worked around this by using:

 

VERSION=$(jq  --raw-output '.Version' /opt/atlassian/pipelines/agent/build/.bitbucket/pipelines/generated/pipeline/pipes/aws-lambda-deploy-env)

 

Not ideal but it's allowed my pipeline to work 

Must be a bug because here you can find an example of a correct usage: https://bitbucket.org/blog/updates-to-bitbucket-pipes.

For example: To access the aws-lambda-deploy-env file from the aws-lambda-deploy pipe you would write:

cat $BITBUCKET_PIPE_SHARED_STORAGE_DIR/atlassian/aws-lambda-deploy/aws-lamda-deploy-env


It's just what @rizwanaparveen.abdulla tried to achieve.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

📣 Calling Bitbucket Data Center customers to participate in research

Hi everyone, Are you Bitbucket DC customer? If so, we'd love to talk to you! Our team wants to dive deep to understand your long-term plans regarding Bitbucket DC and Atlassian Cloud. Do you plan...

218 views 2 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you