Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,293,371
Community Members
 
Community Events
165
Community Groups

can't access old private repository (from 2013)

Edited

hi,

 

me and my friend worked on a side project back in 2013 using bitbucket with mercurial.

however, attempts to access the repository today lead to:

That link has no power here

 

how can we regain access to our repository?

any help would be appreciated...

 

Lev.

1 answer

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

0 votes

This error usually happens when you have given it a bad url - either

  • the url is a functional one, but there's nothing there on the parameters given (imagine "I want to admin thngy so I go to https://service/admin and tell it thingy with a parameter - https://service/admin?thingy", but while the admin page is there, thingy was renamed or deleted)
  • the url is valid but your account has no access to it
  • the url is malformed (padded with / was the one I remember - Sourcetree had a bug that made it put extra / into urls sometimes, and those broke the Bitbucket link with the error you're seeing)

If you've not looked at this repo for 8 years, my guess would be a the first - the repo has moved location, as Bitbucket has changed a lot in that time.

But I would begin to check all three first with a simple look at the url you are using.  Could you give it to us here (with the repo and/or site name obscured)?

For example, I have https://bitbucket.org/sxxxxxxxxxxs/tyyyyt/admin open at the moment

thanks for the quick response!

I copy-pasted the repository url from one of the commit mails that I have from the time we actively worked on this project, so it shouldn't be malformed.. It sounds likely that something changed during 8 years.. 

the form of the url is straight-forward:

https://bitbucket.org/username/project_name

if I remove the <project_name> from the url I do get to the expected destination, however our project isn't there..

TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,087 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you