Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

bitbucket.org is not answering in Ubuntu 14.04 Edited

Hello, 

I cant access bitbucket.org. I'm using Linux Ubuntu 14.04.

On other computers on the same network access is normal..

ping bitbucket.org does not return anything.

 

I think it's a problem on my machine, but I can not identify it.

 

Any idea?

 

Thanks.

 

2 answers

1 accepted

1 vote
Answer accepted

Bitbucket.org does not respond to ping.  What do you get in a browser?  That might help tell you if it's a dns or routing problem, or if your networking is just blocking it.

Hello,

Browser does not return anything... the browser stay in loadging state, does not arrive show the timeout... What I'm using is Chrome version 70.0 x64, but I've tested it on other browsers and it does not load on any...

I can not even clone projects that are on bitbucket...

That is nicely consistent, you've run a lot of the tests I would try.

The evidence is that your network is blocking the access you want to have.  You will need to talk to your network admins to make sure it can route to bitbucket.org

I do not think it's a problem in my network. Because I connected the computer to another network and the problem continued...

Maybe it's something on the machine itself.

Some configuration that needs to be made or repaired...

Thanks for the answer.  I'll leave the question open, maybe someone has gone through it and can share the solution.

Ok, so it's a network problem on your machine.  I think of "the network" as being everything from the client software through to the service on the server.

The client software itself (the browser) is working, but there is something stopping it getting to bitbucket.org.  As you've ruled out the network between the machine and the service, it's the networking functions on that machine that are broken.

Note though, if the client is a browser, then browsers have functions that can interfere with networking - blocking javascript, part or all of sites, adverts etc.  Have you tried another browser?

Yes, I tried to open in other browsers and none returned.

curl bitbucket.org, does not return anything...

I did a traceroute look at the result:

 

traceroute bitbucket.org
traceroute to bitbucket.org (104.192.143.3), 30 hops max, 60 byte packets
1 192.168.2.1 (192.168.2.1) 5.804 ms 9.791 ms 13.923 ms
2 * * *
3 10.10.0.252 (10.10.0.252) 27.288 ms 27.298 ms 35.643 ms
4 172.16.110.9 (172.16.110.9) 35.515 ms 35.514 ms 41.107 ms
5 197.140.101.177.dynamic.ampernet.com.br (177.101.140.197) 71.040 ms 71.015 ms 70.916 ms
6 129.33.186.200.sta.impsat.net.br (200.186.33.129) 63.063 ms 27.479 ms 22.994 ms
7 ae1-300G.ar5.MIA1.gblx.net (67.17.94.249) 130.045 ms 130.079 ms 132.807 ms
8 * * *
9 * * *
10 ATLASSIN-IN.ear3.Seattle1.Level3.net (4.16.168.254) 225.419 ms 231.887 ms 231.781 ms
11 * * *
12 * * *
13 * * *
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *
23 * * *
24 * * *
25 * * *
26 * * *
27 * * *
28 * * *
29 * * *
30 * * *

Here ends.

jredmond Atlassian Team Dec 03, 2018

Do you have an entry in /etc/hosts for bitbucket.org? That IP (104.192.143.3) has not been valid in several months.

Like giquieu likes this

Hello Jim,

Yes it was there! I have removed the line from the hosts and it is now working! rsrss

Many thanks for the reply!

I also want to thank Nic for his time!

After removing entry in /etc/hosts for bitbucket.org? That IP (104.192.143.3) . I resolved the issue

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Powering DevOps with Bitbucket Server & Data Center

Hi everyone, The Cloud team recently announced 12 new DevOps features that help developers ship better code, faster   ! While we’re all excited about the new improvements to Bitbucket ...

1,826 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you