Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,527
Community Members
 
Community Events
165
Community Groups

bitbucket home deleted(renamed) after upgrade

yesterday, I upgraded bitbucket server from 7.11.2 to 7.17.1 and it worked well so far.

only thing I mentioned was, that it didn't run with oracle jdk but opendjdk.

tonight, at midnight (0:00), the bitbucket home directory 'application' was renamed to 'application.deleted' and a new one was created.. but this was nearly empty. only share and log inside.

log sais nothing more that db couldn't connect.. (i suppose, it didn't really have one)

renaming the .deleted folder back solved this. I also took care that oracle jdk runs bitbucket.

But why did that happen and will it re-happen tonight?

2 answers

1 accepted

0 votes
Answer accepted

new info on this. Seems, that this was a feature of ansible.
Since bitbucket installer always creates user atlbitbucket but our configuration management software only has 8 letters, we use user git for bitbucket.
re-owning of the application directory led to a fatal reaction of ansible. Same problem could occour when we update confluence (user confluen) next time..
Would be nice if atlassian installers enable a user setting.. (as i coincidentally requested today.. https://jira.atlassian.com/browse/BSERV-13066)

1 vote

Hi Jens,

This is nothing that Bitbucket Server does on its own so it must be something on your system.

Cheers,

Christian

Premier Support Engineer

Atlassian

well, on one hand, I hoped for that answer..

... on the other hand, it scares me a little since I don't have a clue what happened there..

Yet another micaculous thing to keep an eye on ;-)

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

2,230 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you