Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

bitbucket claims my repo is 1.6GB, but it's only 460M

Edited

When I push to bitbucket, I get the following warning: 

remote: WARNING Repository size in Bitbucket is currently 1.6 GB

But if I clone the repo, it's only 460M

$ git clone git@bitbucket.org:my_team/my_repo.git
$ du -sh
460M .
$ du -sh ./.git
257M ./.git

Can I get bitbucket to recognize that I've actually only used 460M?

 

I already tried 2 variations of the advice here.

git clone git@bitbucket.org:astappteam/mobile_app.git
git checkout -b bitbucket-gc
git reset --hard HEAD~1
git push --set-upstream origin bitbucket-gc


git checkout dev
git checkout -b bitbucket-gc1
git push --set-upstream origin bitbucket-gc1
git reset --hard HEAD~1
git push --force

2 answers

0 votes
Tyler T Atlassian Team Apr 20, 2020

Hi @Ellen_Sebastian and welcome the Community!

From my end it looks like the repository size has gone down. It may have taken some time for garbage collection to run after you updated the repository.

Are you still having an issue?

Right, I no longer see the warning. I can't see the repo size either, so I don't know whether bitbucket currently detects 460M, 920MB, or anything else. 

I guess one of these steps fixed it, or else there was some bug in bitbucket that was fixed

git clone git@bitbucket.org:astappteam/mobile_app.git
git checkout -b bitbucket-gc
git reset --hard HEAD~1
git push --set-upstream origin bitbucket-gc


git checkout dev
git checkout -b bitbucket-gc1
git push --set-upstream origin bitbucket-gc1
git reset --hard HEAD~1
git push --force

Hi @Ellen_Sebastian ,

I have the same problem, you need to view the repository settings in your bitbucket account and you will see the real size of your repo.

How solve the problem, I created a new repo, I know if not the best solution, but I tried, all the possible methods but is the only solution that I found (see the following link if you can find other possible solution https://confluence.atlassian.com/bitbucket/reduce-repository-size-321848262.html)

My recommendation, don't commit blob files in your repo.

Best.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,888 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you