application.wadl missing parameters for many commands in Bitbucket Server

I started using the REST API Browser and noticed that many of the commands do not give me a chance to fill in some of the "template" parameters, such as /rest/api/1.0/projects/{projectkey}/repos/{repositorySlug}/branches

For that page there is no place to enter the two template variables above, but there is plenty for parameters passed on the query string.

Compare with /rest/api/1.0/projects/{projectkey}/repos/{repositorySlug}, which has the two necessary parameters.

The problem appears to be the application.wadl file (http://bitbucket.dtex.lan:7990/rest/api/1.0/application.wadl). The problematic methods are missing the param elements for the template variables (style="template").

Tried raising this as a bug but the ticking system directed me here.... I think :)

0 answers

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

440 views 6 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you