application.wadl missing parameters for many commands in Bitbucket Server

I started using the REST API Browser and noticed that many of the commands do not give me a chance to fill in some of the "template" parameters, such as /rest/api/1.0/projects/{projectkey}/repos/{repositorySlug}/branches

For that page there is no place to enter the two template variables above, but there is plenty for parameters passed on the query string.

Compare with /rest/api/1.0/projects/{projectkey}/repos/{repositorySlug}, which has the two necessary parameters.

The problem appears to be the application.wadl file (http://bitbucket.dtex.lan:7990/rest/api/1.0/application.wadl). The problematic methods are missing the param elements for the template variables (style="template").

Tried raising this as a bug but the ticking system directed me here.... I think :)

0 answers

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

706 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot