Your account does not have an e-mail address associated with it.

When I do a git push to remote I get this message:

remote: Warning!
remote: Your account does not have an e-mail address associated with it.
remote: Please set one by visiting https://bitbucket.org/account/user/USERNAME/email/

 

However on that link there is a message that reads:

Adding email addresses to teams is no longer supported

 

How can this be solved so I don't get this message every time?

4 answers

1 accepted

0 votes
Accepted answer

I don't have much experience with this, but it sounds like you're using credentials for the team itself, when you should be using credentials of a team member.

I'm using git & Bitbucket from long time but I've the this warning since shortly.

Where can I configure email asked ? 

@Seth : How can I use credentials of a team member in place of the team itself ?

The username you use to connect is probably in your remote URL. You can edit that in your repository's .git/config file.

I directly contacted Atlassian. Their response resolves my issue !

"It seems to be that there is an SSH key added in your team account which could be the reasons you're facing this issue. The SSH key should be added in the individual account associated to the team. Also, BitBucket does not support team login so the teams are not associated with an email address but are associated with individual accounts which means an email address, unfortunately, can not be added to a team account.

So what you can do is, try removing the SSH key from the team account and try adding it to the individual account associated to the team."

Thanks - I was having the same issue; this solved the problem.

I'm using a team repository, I commit/push like an user from this team and Atlassian seems to have disabled email addresses to teams since shortly.

My .git/config [local] (and my ~/.gitconfig [global]) files are okay :

[user]
    name = Bitbucket User Name
    email = personnal@email.com

My Bitbucket account is well configured, with same user name and email and is an administrator in the team of the repo. But in the warning, it's not my personal email but my group email is in error :

remote: Warning! 
remote: Your account does not have an e-mail address associated with it. 
remote: Please set one by visiting https://bitbucket.org/account/user/**group_name**/email/ 
remote:

But I can't add an email to a team from Bitbucket ("Adding email addresses to teams is no longer supported") & I can't change my repository to a single a user. So, it seems this error can't be solved…

Look at the URL you use to specify the remote repository. it should be something like <protocol>://<username>@bitbucket.org/<pathToRepo> Is <username> the username for your personal account, or the one for your team account? The details in [user] are completely independent from your bitbucket account info.

Had this problem too, it also set the default color on my terminal to red ._.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

454 views 5 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you