Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,458,191
Community Members
 
Community Events
176
Community Groups

Yarn install always hangs up in my pipelines

I've been trying to set up some pipeline deployments for my node API but no matter what I do the yarn(or yarn install) commands gets to "[4/4] Building fresh packages... "and then hangs up. I've waited over 20 minutes to see if it's just being slow but it's never finished.

 

Is there a cause for this or something I can do to get past this step? This issue doesn't exist on my laptop or server, just pipelines.

Screen Shot 2023-01-26 at 10.58.05 AM.png

1 answer

0 votes

@BradyEdgar94  hi. Try this command:

yarn install --non-interactive

But also i suggest you to take a look at our pipes marketplace. There are some of them to work with the node and maybe they will cover your case.

Regards, Igor

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events