Why can't I push to the remote repository, says error: index file

Good afternoon,

I've been having a problem with getting some new files in my local repository to be pushed to the remote repository. The files are about 10Gb. For a long time, it's been saying things like ( fatal: Out of memory, malloc failed) and the remote being timed out. I've tried a couple things like:

  • git repack -adf --window-memory=100
  • git remote set-url origin https://github.com/USERNAME/REPOSITORY.git

None of these things worked for me. they brought back nothing but errors and time outs. What can I do? below are some snippets to show:

 

failedpush1.PNG

erropush3.PNG

 

errorpush.PNG

 

 

 

1 answer

0 votes
Hi Thomas, those errors are usually related to file system corruption. You might have also ran out of disk space at some point. Can you check that?
Regards,
Ana

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

654 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot