It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

When running 'atlas-run' and opening http://localhost:7990/bitbucket I see only 404 since recently

The error looks like screenshot.png

i.e. "The requested resource is not available".

I start 'atlas-run' and open http://localhost:7990/bitbucket in the browser.

The command runs without any error but ends with these lines

 

[INFO] [talledLocalContainer] мая 16, 2017 8:41:29 PM org.apache.coyote.AbstractProtocol start
[INFO] [talledLocalContainer] INFO: Starting ProtocolHandler ["http-nio-7990"]
[INFO] [talledLocalContainer] мая 16, 2017 8:41:29 PM org.apache.coyote.AbstractProtocol start
[INFO] [talledLocalContainer] INFO: Starting ProtocolHandler ["ajp-nio-8009"]
[INFO] [talledLocalContainer] мая 16, 2017 8:41:29 PM org.apache.catalina.startup.Catalina start
[INFO] [talledLocalContainer] INFO: Server startup in 25137 ms
[INFO] [talledLocalContainer] Tomcat 8.x started on port [7990]
[INFO] bitbucket started successfully in 64s at http://dmit10:7990/bitbucket
[INFO] Type Ctrl-D to shutdown gracefully
[INFO] Type Ctrl-C to exit

while earlier when everything were working, these lines were not the last in the output.

 

JDK is by Oracle of version 1.8.0u131

$ atlas-version

ATLAS Version:    6.2.14                                                                                                                                                                                                          
ATLAS Home:       /usr/share/atlassian-plugin-sdk-6.2.14                                                                                                                                                                          
ATLAS Scripts:    /usr/share/atlassian-plugin-sdk-6.2.14/bin                                                                                                                                                                      
ATLAS Maven Home: /usr/share/atlassian-plugin-sdk-6.2.14/apache-maven-3.2.1                                                                                                                                                       
AMPS Version:     6.2.11                                                                                                                                                                                                          
--------                                                                                                                                                                                                                          
Executing: /usr/share/atlassian-plugin-sdk-6.2.14/apache-maven-3.2.1/bin/mvn --version -gs /usr/share/atlassian-plugin-sdk-6.2.14/apache-maven-3.2.1/conf/settings.xml                                                            
Apache Maven 3.2.1 (ea8b2b07643dbb1b84b6d16e1f08391b666bc1e9; 2014-02-14T18:37:52+01:00)                                                                                                                                          
Maven home: /usr/share/atlassian-plugin-sdk-6.2.14/apache-maven-3.2.1                                                                                                                                                             
Java version: 1.8.0_131, vendor: Oracle Corporation                                                                                                                                                                               
Java home: /usr/lib/jvm/jdk1.8.0_131/jre                                                                                                                                                                                          
Default locale: ru_RU, platform encoding: UTF-8                                                                                                                                                                                   
OS name: "linux", version: "3.16.0-4-amd64", arch: "amd64", family: "unix"                                                                                                                                                        
                                                                                                                                                                                                  

The version of Bitbucket mentioned in the output was 5.0.0. (bitbucket-webapp-5.0.0.war) I also tried to run "atlas-run-standalone --product bitbucket" with the same result with the difference that the bitbucket server version was 5.0.1.

 

What about logs in target/bitbucket/home/log directory, they are nearly empty:

$ cat atlassian-bitbucket.log
$ cat atlassian-bitbucket-profiler.log
$ cat atlassian-bitbucket-access.log 
172.17.0.7 | http | i@179BY0Xx240x1x0 | - | 2017-05-04 04:00:08,081 | "GET / HTTP/1.1" | "" "Java/1.8.0_112" | - | - | - | - | - | - | 
172.17.0.7 | http | o@179BY0Xx240x1x0 | - | 2017-05-04 04:00:08,370 | "GET / HTTP/1.1" | "" "Java/1.8.0_112" | 302 | 0 | 0 | - | 290 | - | 
172.17.0.7 | http | i@179BY0Xx240x2x0 | - | 2017-05-04 04:00:08,377 | "GET /dashboard HTTP/1.1" | "" "Java/1.8.0_112" | - | - | - | - | - | - | 
172.17.0.7 | http | o@179BY0Xx240x2x0 | - | 2017-05-04 04:00:08,388 | "GET /dashboard HTTP/1.1" | "" "Java/1.8.0_112" | 302 | 0 | 0 | - | 10 | - | 
172.17.0.7 | http | i@179BY0Xx240x3x0 | - | 2017-05-04 04:00:08,391 | "GET /login HTTP/1.1" | "" "Java/1.8.0_112" | - | - | - | - | - | - | 
172.17.0.7 | http | o@179BY0Xx240x3x0 | - | 2017-05-04 04:00:08,939 | "GET /login HTTP/1.1" | "" "Java/1.8.0_112" | 200 | 0 | 10476 | - | 547 | - | 
127.0.0.1 | http | i@179BY0Xx240x4x0 | - | 2017-05-04 04:00:11,983 | "POST /rest/api/latest/projects HTTP/1.1" | "" "Apache-HttpClient/4.5.1 (Java/1.8.0_112)" | - | - | - | - | - | - | 
127.0.0.1 | http | o@179BY0Xx240x4x0 | admin | 2017-05-04 04:00:13,668 | "POST /rest/api/latest/projects HTTP/1.1" | "" "Apache-HttpClient/4.5.1 (Java/1.8.0_112)" | 201 | 87 | 206 | - | 1685 | - | 
127.0.0.1 | http | i@179BY0Xx240x5x0 | - | 2017-05-04 04:00:13,777 | "POST /rest/api/latest/projects/PROJECT_1/repos/ HTTP/1.1" | "" "Apache-HttpClient/4.5.1 (Java/1.8.0_112)" | - | - | - | - | - | - | 
127.0.0.1 | http | o@179BY0Xx240x5x0 | admin | 2017-05-04 04:00:14,054 | "POST /rest/api/latest/projects/PROJECT_1/repos/ HTTP/1.1" | "" "Apache-HttpClient/4.5.1 (Java/1.8.0_112)" | 201 | 30 | 614 | - | 276 | - | 
0:0:0:0:0:0:0:1 | http | i@179BY0Xx240x6x0 | - | 2017-05-04 04:00:14,454 | "GET /scm/PROJECT_1/rep_1.git/info/refs HTTP/1.1" | "" "git/2.11.0" | - | - | - | - | - | - | 
0:0:0:0:0:0:0:1 | http | o@179BY0Xx240x6x0 | - | 2017-05-04 04:00:14,470 | "GET /scm/PROJECT_1/rep_1.git/info/refs HTTP/1.1" | "" "git/2.11.0" | 401 | 0 | 0 | - | 16 | - | 
0:0:0:0:0:0:0:1 | http | i@179BY0Xx240x7x0 | - | 2017-05-04 04:00:14,472 | "GET /scm/PROJECT_1/rep_1.git/info/refs HTTP/1.1" | "" "git/2.11.0" | - | - | - | - | - | - | 
0:0:0:0:0:0:0:1 | http | o@179BY0Xx240x7x0 | admin | 2017-05-04 04:00:14,577 | "GET /scm/PROJECT_1/rep_1.git/info/refs HTTP/1.1" | "" "git/2.11.0" | 200 | 0 | 180 | refs | 104 | - | 
0:0:0:0:0:0:0:1 | http | i@179BY0Xx240x8x0 | - | 2017-05-04 04:00:14,613 | "POST /scm/PROJECT_1/rep_1.git/git-receive-pack HTTP/1.1" | "" "git/2.11.0" | - | - | - | - | - | - | 
0:0:0:0:0:0:0:1 | http | o@179BY0Xx240x8x0 | admin | 2017-05-04 04:00:14,920 | "POST /scm/PROJECT_1/rep_1.git/git-receive-pack HTTP/1.1" | "" "git/2.11.0" | 200 | 8726 | 265 | push | 306 | - | 
127.0.0.1 | http | i@179BY0Xx240x9x0 | - | 2017-05-04 04:00:14,954 | "PUT /rest/analytics/1.0/config/acknowledge HTTP/1.1" | "" "Apache-HttpClient/4.5.1 (Java/1.8.0_112)" | - | - | - | - | - | - | 
127.0.0.1 | http | o@179BY0Xx240x9x0 | admin | 2017-05-04 04:00:15,834 | "PUT /rest/analytics/1.0/config/acknowledge HTTP/1.1" | "" "Apache-HttpClient/4.5.1 (Java/1.8.0_112)" | 200 | 0 | 0 | - | 879 | - | 
127.0.0.1 | http | i@179BY0Xx240x10x0 | - | 2017-05-04 04:00:15,849 | "PUT /rest/nps/1.0/status/acknowledge HTTP/1.1" | "" "Apache-HttpClient/4.5.1 (Java/1.8.0_112)" | - | - | - | - | - | - | 
127.0.0.1 | http | o@179BY0Xx240x10x0 | admin | 2017-05-04 04:00:16,321 | "PUT /rest/nps/1.0/status/acknowledge HTTP/1.1" | "" "Apache-HttpClient/4.5.1 (Java/1.8.0_112)" | 200 | 24 | 0 | - | 472 | - | 
127.0.0.1 | http | i@179BY0Xx240x11x0 | - | 2017-05-04 04:00:16,343 | "POST /rest/stp/1.0/license/remindMeNever HTTP/1.1" | "" "Apache-HttpClient/4.5.1 (Java/1.8.0_112)" | - | - | - | - | - | - | 
127.0.0.1 | http | o@179BY0Xx240x11x0 | admin | 2017-05-04 04:00:16,933 | "POST /rest/stp/1.0/license/remindMeNever HTTP/1.1" | "" "Apache-HttpClient/4.5.1 (Java/1.8.0_112)" | 200 | 0 | 0 | - | 589 | - | 

I should also mentioned that I tried that on 2 different computers with Debian on them and on each of 2 add-ons I develop, all ended with the same result. The code of one of the add-ons hasn't been changed at all since the last time "atlas-run" was working. I always do "atlas-clean" before running "atlas-run" or "atlas-run-standalone".

I saw a lot of similar issues related to JIRA 2-3 years old but they all recommend running JIRA twice, but for me running Bitbucket Server twice, trice, etc doesn't help at all.

Could you help me somehow?

1 answer

This solves the problem, thanks!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bitbucket

Atlassian supported Jenkins integration for Bitbucket Server

We’ve been building a plugin to integrate Bitbucket Server and Jenkins CI, and I’m excited to announce that our alpha is ready to download and install. It lets you seamlessly configure a Jenkins job ...

990 views 1 17
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you