Webhook gives 404 when trying to auto deploy

Hi!

When I try to push a change from SourceTree I can't get Bitbucket to auto deploy. I tried following this tut: https://bitbucket.org/lilliputten/automatic-bitbucket-deploy/ and this one: http://blog.mobnia.com/bitbucket_automated_deployment/ (which is a bit more extensive)

I followed the tutorials as much as possible, but at the second one at the bottom it tells me to create a configuration in my webserver, which I have no idea how to do. I've tried searching, but nothing.

I'm not even sure if this is the problem. The ssh keys are working and when I do a pull from the terminal it seems to work. Just the webhook I made in my repository doesn't seem to be working.

When I try to access the folder (http://travelaar.com/automatic-bitbucket-deploy/test.php) with a test file I've made, I get a 404 in my browser.

Could this cause the issue?

This is the first time I fiddle with a terminal and I just know what is in the tuts..

0 answers

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

2,025 views 1 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you