Use cache for node build

Hello,

I use Bitbucket pipeline to perform test on my project.

Here is my .yml :

image: node:8.3
pipelines:
  default:
    - step:
        caches:
          - node
        script:
          - cd build
          - npm install
          - npm test

I have this error during the process :

Cache "node": Not found

So I try this :

image: node:8.3
pipelines:
  default:
    - step:
        caches:
          - node
        script:
          - cd build
          - npm install
          - npm test
definitions:
  caches:
    node: build/node_modules

But none seems to work.

 

How could I solve this ?

0 answers

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jun 12, 2018 in Bitbucket

Do you use any Atlassian products for your personal projects?

After spinning my wheels trying to get organized enough to write a book for National Novel Writing Month (NaNoWriMo) I took my affinity for Atlassian products from my work life and decided to tr...

27,767 views 26 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you