Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Unknown SHA1 object


Hi, all of a sudden pipelines can no longer push to remote servers via FTP - has been working well for years.


No matter what I try and just get back "Unknown SHA1 object"

Every time it simply wants to try and "re-upload" all the files to the remote server as a solution.


I have hundreds of files (1.5g) and and pushing out to several sites - so this is not really an option.


Is there some way of setting these remote hash files to a specific hash so that things can proceed or someway of fixing this - incredibly frustrating.


git config git-ftp.syncroot .



To add to this: 

I was using this image from docker hub which is throwing the errors:





Err:5 stable/updates Release 404 Not Found [IP: 80]Reading package lists...E: The repository ' stable/updates Release' does not have a Release file.





Seems like there is a problem with Debian 11 security files not being compatable.


More info on the issue here.






For remote FTP hash keys that are out of sync - get a previous one that works and paste it into your git-ftp.log file on your remote server. You can get this by viewing the actual update files and the key is at the top.


Temporary solution for the

image: samueldebruyn/debian-git

no longer working is to use

image: image: bitnami/git


Hope this helps someone.


0 answers

Suggest an answer

Log in or Sign up to answer

Atlassian Community Events