Stash not starting after running "service atlstash start" (centos 6.6)

Hello,

I was attempting to set up stash to use SSL (following the directions found here: https://confluence.atlassian.com/display/STASH/Securing+Stash+with+Tomcat+using+SSL).  Before today stash has been up and running for 2 months with no issues.

After searching through my system, I made 2 changes: server.xml and creating a key through the java keytool.

For server.xml, first I copied server.xml into server-backup.xml, then made changes to server.xml.  Then I ran the java keytool to create a self-signed certificate using the instructions on the page.  After stopping stash and re-starting it, I was then unable to access the stash web-page.  I gave it a few minutes and tried again.  Then I checked service atlstash status, and it told me "Stash is not running".

I then rolled back my changes (changed server-backup.xml back to server.xml, and deleted the key made by the java keytool), and rebooted the server.  After the server came back online, I then ran "service atlstash start" and it did its usual pop-up script.  Then running "service atlstash status" I get "Stash is not running".  I've tried restarting both the server and stash again, but stash now won't start.

What can I do to get this back up and running again?

Edit: Further details after researching into the issue

From "opt/atlassian/stash/3.8.0/logs/catalina.out" the last few lines have all contained variations of:

/opt/atlassian/stash/3.8.0/bin/catalina.sh: line 399: /usr/lib/jvm/jre-1.8.0-openjdk-1.8.0.51-0.b16.el6_6.x86_64/jre/bin/bin/java: No such file or directory

note that I have 12 different versions of java in the folder "/usr/lib/jvm", and at this point I have tried setting the java home directory as each and every single one of them.  I've also checked that in each of them, there is a file named java.  So I don't know why it can't detect any of these when that data is there for it to see.  I have also tried restarting the server, or just restarting my connection each time that I change the java home directory.  So at least my problem has been narrowed down, but I still don't know how to fix it.

1 answer

This widget could not be displayed.

Hi Colin,

The problem seems to be related to this section of the error message .../jre/bin/bin/java. My guess is that you are exporting JAVA_HOME and including the bin folder, the JAVA_HOME variable should contain the path to your JDK and not the bin folder. In your case try exporting JAVA_HOME like this:

export JAVA_HOME=/usr/lib/jvm/jre-1.8.0-openjdk-1.8.0.51-0.b16.el6_6.x86_64/jre/

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 21, 2018 in Bitbucket

Branch Management with Bitbucket

As a project manager, I have discovered that different developers want to bring their previous branching method with them when they join the team. Some developers are used to performing individual wo...

1,261 views 8 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you