Stash Installation Service Conflict?

Hi All,

I'm trying to setup an eval installation of Stash on our test server already running test environments of JIRA and Confluence (Windows Server 2003 connecting to an external MS SQL 08 DB).  JIRA and Confl. are setup on two separate IPs on the same machine.

Probably not ideal, but I was hoping to install Stash, with its default 7990 port to run under one of those IPs, just to get it working easily.  I am pretty clueless when it comes to network setup, as I'm primarily a developer (and most of the web server experience I have is with IIS, so this Tomcat stuff is new to me).  Anyway, when I run the Stash installer and attempt to "Install Stash as a service", I get this error message:

"It looks like a Stash service is already installed in the target environment.  The installation will replace any existing services.  Do you want to continue?"  This scares me a bit, as I suspect it's meant to do smile, so I say no and back out of the install.

As far as I know/can tell, no one has ever tried to install Stash on this server before me.  I can see the "Atlassian JIRA" and "Atlassian Confluence" services in the Windows Services list, but nothing in there about Stash.  The Stash install and home directories are new folders on this machine.  I also ran a "netstat -an" to see if anything was already on that 7990 port and found nothing.

I assumed this warning came from already having a service named exactly as the installer would name the new service ("Atlassian Stash"?), but there is none already with that name (or anything remotely similar to "stash").  So, I'm stumped.

Do any of you have any idea what's going on or where/what I can check?  Maybe someone did try installing Stash a while ago, removed it, and something was left behind, but I wouldn't know where to look.

Thanks!

Justin

1 answer

I went ahead with the installation regardless of the warning message, since we figured we could recreate any services the install clobbered. However, the install is now frozen at what looks like the very end (progress bar fully filled) with "Extracting files..." displayed. I found this other user's question, which is similar, except that I couldn't actually find any previous stash service to delete (as he'd done): https://answers.atlassian.com/questions/9882024/stash-installer-stuck-on-windows-2003 In my case, over an hour after it froze, still no progress on the installer. The INSTALL directory has been created and filled. The HOME dir is there and empty (maybe it's only populated after the initial setup process?). The "Atlassian Stash AtlassianStash" service was created, but not started yet. I found this in a log file (STASH_INSTALL\logs\commons-daemon.2014-12-08.log): [2014-12-08 15:18:01] [info] [ 2988] Commons Daemon procrun (1.0.15.0 32-bit) started [2014-12-08 15:18:01] [info] [ 2988] Deleting service... [2014-12-08 15:18:02] [error] [ 2988] The specified service does not exist as an installed service. [2014-12-08 15:18:02] [info] [ 2988] Delete service finished. [2014-12-08 15:18:02] [error] [ 2988] Commons Daemon procrun failed with exit value: 9 (Failed to delete service) [2014-12-08 15:18:02] [info] [ 5572] Commons Daemon procrun (1.0.15.0 32-bit) started [2014-12-08 15:18:03] [info] [ 5572] Service AtlassianStash name Atlassian Stash AtlassianStash [2014-12-08 15:18:05] [info] [ 5572] Service 'AtlassianStash' installed [2014-12-08 15:18:05] [info] [ 5572] Commons Daemon procrun finished [2014-12-08 15:18:06] [info] [ 5636] Commons Daemon procrun (1.0.15.0 32-bit) started [2014-12-08 15:18:06] [info] [ 5636] Updating service... [2014-12-08 15:18:07] [info] [ 5636] Service 'AtlassianStash' updated [2014-12-08 15:18:07] [info] [ 5636] Update service finished. [2014-12-08 15:18:07] [info] [ 5636] Commons Daemon procrun finished That time, 3:18pm, is about when the installer stopped doing anything. So, I'm probably going to kill the installer and then recreate whatever is backed out manually. Does anyone have any idea why I'm having all this trouble? I'm guessing it has something to do with the installer stumbling over the "already existing" stash service, even though I could find no evidence of it. Thanks! Justin

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

1,768 views 1 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you