Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree user login failure, sometimes

I have a user that is getting a user authentication failure when attempting to clone a repo from Bitbucket in Sourcetree on Windows 10.

The behavior is somewhat weird. On the Remote tab in Sourcetree they can see the repository list, but when they go to clone a repo they get an authentication error. The weird parts are as follows.

If we use a different Bitbucket username/password we can do a clone.

If we skip Sourcetree and use Git on the command line we get the same result. Again using a different Bitbucket username/password works.

I have tried all of the methods I could find online to remove the stored credentials. The authentication tab in Sourcetree, Windows credential Manager, deleting Sourcetree folders, etc. We have also tried multiple versions of Sourcetree, doing uninstalls in between.

It seems that Git is using different credentials not from Sourcetree that are incorrect/corrupted in some way. 

Any ideas what else I might be able to try. Don't really want to change the users username or reimage their PC, as they have a lot of other dev tools set up that are working.

 

1 answer

0 votes

Hi John,

If the user's Bitbucket account has an email from a domain that has been verified as per this doc, and SAML is used for logging in to this account, then the account's password won't work for HTTPS authentication when cloning/pulling/pushing from/to Bitbucket.

In this case, the user can generate an app password for their Bitbucket Cloud account and use that instead of a password for purposes of cloning etc:

I would suggest trying an app password anyway, for testing purposes, and if it works they can continue working with it if they want.

If you ask the user to leave a comment in this Community post (using a Community account with the same email as their Bitbucket Cloud account), I'll be able to see their email and confirm whether SAML is used for logging in to this account and if that's the cause for the issue.

If this is not the case, then we can investigate further. It would still be good to be able to talk with the user directly in the post here, instead of asking you to pass along suggestions and replies back and forth.

Kind regards,
Theodora

Hello,

Thanks for the feedback.

We are currently using Atlassian Access or SAML at this time. We tried using an app password and that did not work.

I will ask the user to make a post for more direct communication.

Like Theodora Boudale likes this

I have asked the user to post to this thread.

Like Theodora Boudale likes this

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS
Community showcase
Published in Bitbucket

📣 Calling Bitbucket Data Center customers to participate in research

Hi everyone, Are you Bitbucket DC customer? If so, we'd love to talk to you! Our team wants to dive deep to understand your long-term plans regarding Bitbucket DC and Atlassian Cloud. Do you plan...

192 views 2 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you