SSL3_GET_RECORD:wrong version number

Hello.

I have few machines which run Ubuntu Trusty (14.04) in production. I was able to 'hg pull' from those up until few days ago.

Today I tried to push my changes to production, and when running 'hg pull' I get this error:

 

abort: error: _ssl.c:510: error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number

I was assuming that I had old python installation that doesn't support TLS1.2, but that doesn't seem to be the case:

 

 # python -c "import json, urllib2; print json.load(urllib2.urlopen('https://www.howsmyssl.com/a/check'))['tls_version']" 
TLS 1.2

 
Has anything changed on bitbucket's side, as 'hg pull' was working ok few days ago?

Thank you in advance,

Mario

4 answers

I too, am getting this error out of the blue now. I am not sure how to fix it, it was working a few days ago. 

 

Nothing has changed on my side to introduce the error. I tried updating to 3.0.8 as a result and get the same error.

 

I am on W10.

It seems bitbucket canceled support for TLS1.0 and TLS1.1, and pyhon2.7.6 on Trusty can't do TLS1.1 automatically. 

But, I was wrong in using https, switched to ssh and now it works fine.

I'm sorry, I don't use Windows so I have no idea about python and TLS and ssh there.

Mine seems to be repo related.

 

I have several repos on BitBucket using SourceTree to access them. One repo gets the error while another does not.

EDIT: Strangely enough, I cloned the repo again and I was able to check-in fine. Something occurred with my repo on my local drive that is causing this error. 

I did try to switch to SSH, which did not fix the error. But cloning to a new folder worked fine. After copying my changes over that previously would not check-in due to the error, it went smoothly. First time seeing this in several years of using SourceTree + BitBucket. I am not entirely sure what the root cause is, but at least I can check-in now.

This is the issue I've seen; it seems exactly the same:

mkpresco06bd:arcosie kfinlator$ hg push
pushing to https://kfinlator@bitbucket.org/kfinlator/arcosie
abort: error: _ssl.c:510: error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number

I am using hg version 3.2 along with Python 2.7.8 on a Mac, OS X 10.11.6. I was not seeing this issue as recently as 11/16/2018, but I saw it starting yesterday when attempting to push updates from my mac. I did not see this same issue from any of several different Linux machines when managing clones of the same repository. In all cases, the local repository is configured to connect using https. So it's specific to the way that this Mac communicates using https.

I switched the URL in the .hg/hgrc to indicate an ssh URL and established public/private ssh keys. Now the issue is resolved. Thanks for help!

EDIT: Double post. 

0 votes
Tim Day I'm New Here Dec 05, 2018

I just ran into the same or a similar SSL version issue on an old Debian 8 ("jessie") machine I keep around for various reasons (Debian 9 "stretch"'s hg over https continues to work fine with bitbucket).

On the jessie machine, following the instructions to use ssh rather than https worked fine for me.  Don't forget to update any affected checked-out repos .hg/hgrc default path too.

0 votes
Sander Wubbels I'm New Here Monday

I ran into the same problem. Just discovered it today. I found out I was using an ancient version (v 2.9) of hg. I updated it to the latest version (v 4.7.1) and everything worked fine again!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

426 views 6 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you