S3 deployment failing in pipelines

Sri Puligadda February 28, 2022

I'm trying to run the pipeline using pipe: atlassian/aws-s3-deploy:1.1.0  to deploy to S3.

It was pushing all the files as expected, but the end its giving deployment failed error.

Please can someone throw some light on the issue.

Below is the screenshot of the debug logimage.png

This the was the step in use

 - step:

          name: Deploy to S3

          deployment: uat

          script:

          - pipe: atlassian/aws-s3-deploy:1.1.0

            variables:

              LOCAL_PATH: 'dist/'

              AWS_ACCESS_KEY_ID: $AWS_ACCESS_KEY_ID

              ACL: 'bucket-owner-full-control'

              AWS_SECRET_ACCESS_KEY: $AWS_SECRET_ACCESS_KEY

              AWS_DEFAULT_REGION: $AWS_DEFAULT_REGION

              S3_BUCKET: $S3_BUCKET

              DELETE_FLAG: 'true'

              DEBUG: 'true'

 

2 answers

0 votes
Devendra Saroj August 14, 2023

I encountered the same error, and it wasn't the issue of file name in my case. Tried multiple things, at the end removing `DELETE_FLAG'true'` from variables worked.

0 votes
Ankit Gupta February 28, 2022

Hey Sri,

If it's transferring the files then authentication is working and so is uploading to the bucket. Do you see any other error message except "Deployment failed" as that's quite generic?

Sri Puligadda March 2, 2022

Hi Ankit,

Thanks for the reply.

As you can see in the screenshot, there was some debug info if it can be any help

 

2022-03-02 11:24:55,741 - Thread-1 - awscli.customizations.s3.results - DEBUG - Shutdown request received in result processing thread, shutting down result thread.
status=1
set -e
[[ 1 -eq 0 ]]
fail 'Deployment failed.

Ankit Gupta March 2, 2022

Hi Sri,

This seems like the sync failed with those credentials. You can locally try running the command for sync from here: https://bitbucket.org/atlassian/aws-s3-deploy/src/master/pipe/pipe.sh

It would be able to tell you why the deployment failed.

Sri Puligadda March 3, 2022

Issue was resolved.

Basically there was a file with name which has a non-utf8 character and it was causing the issue.

Thank you

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events