Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,569
Community Members
 
Community Events
176
Community Groups

Required Build Settings

Bitbucket provides required build options to allow specific branches to have successful build before they can be merged. It requires a build key that is the name of the job. However, I can't seem to find the right build key as they job is successful but bitbucket still doesn't allow the merge to happen. 

1 answer

We have the same issue.

We have a mulitbranch pipeline and I cannot get it to match any of the Jenkins build keys.

 

It always tells me that there is a build needed, no matter what I give as key.

I have tried to far:

<project>
<project>/
<project>/*
<project>/<pipeline>
<project>/job/<pipeline>
<project>/<branch>/<pipeline>

nothing works.

Hi Tomas, 

I have set up Bitbucket and Jenkins on virtual machine with integration using Bitbucket server integration plugin and managed to get the required-build to work. The build key is simply the job name. If the job is in folder you must include folder name. However, still having issue to get this to work on the organisation env. Investigating how to resolve it. 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events