Repo too big - can't seem to reduce it

I'm running Git on Windows and one of my repos is over 2 GB. I stupidly copied a large directory to my repo and (again, stupidly) pushed it to my repository. Now, over time, my repo has ballooned to over 2 GB and I can't push to it anymore.

I can't seem to fix this; I've run BFG, tried pruning the repo, etc. Nothing seems to work.

My last step is to delete the repo altogether and start over. Can anyone offer a suggestion on how to do this without having to blast the repo?

Thank you.

1 answer

This widget could not be displayed.

Hi Chris! I found your repo and run a git gc on it, the size has now decreased to 280.5 MB. We run an automated garbage collection in the remote, but sometimes you'll need to contact us to see the change immediately.

Are you able to push to your repo now?

If everything is fine, you can let us know by accepting this answer.

Cheers :)

Thank you, Ana. Turns out I was able to reduce the size once I ran BFG and then gc on the repo again. It didn't work the first time but it worked the 2nd time. 

 

Thank you,
Chris

 

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 21, 2018 in Bitbucket

Branch Management with Bitbucket

As a project manager, I have discovered that different developers want to bring their previous branching method with them when they join the team. Some developers are used to performing individual wo...

1,303 views 8 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you