Problem with SSL after update to 5.3.1 Edited

Hi, i have a problem with SSL settings of my bitbucket. I get non-ssl connection.

Снимок экрана 2017-09-12 в 15.png

Снимок экрана 2017-09-12 в 15.png 

server.secure=true
server.scheme=https
server.additional-connector.1.port=9059
server.additional-connector.1.redirect-port=8443
server.additional-connector.1.require-ssl=true
server.proxy-port=443
server.proxy-name=my.domain.com 

 I use apache proxy with SSL.

What is wrong?

Thanks!

1 answer

This widget could not be displayed.

Hi Stanislav,

I have seen similar issues and one reason was there isn't a path to the keystore in the bitbucket.properties file and

server.additional-connector.1.ssl.enabled=true

was not set.  Verify these settings in your environment and you can take a look at the Communities post titled Solved: Cannot get SSL configured on Bitbucket Server 5.0 for more information.

Cheers,

Branden

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 21, 2018 in Bitbucket

Branch Management with Bitbucket

As a project manager, I have discovered that different developers want to bring their previous branching method with them when they join the team. Some developers are used to performing individual wo...

1,222 views 8 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you