Merge Check plugin problem -Plugin not responding / not working

Hi All,

In my atlas-sdk, in current merge check plug-in , I used atlas-run.Suddenly after showing Live Reload Ended message in command prompt, it is showing a error message

i.e., "ERROR [localhost-startStop-1] c.a.plugin.manager.PluginEnabler Unable to start the following plugins due to timeout while waiting for plugin to enable: com.mycompany.is-admin-merge-check-tests".

My stash server is working fine, but the plugin is not working properly..

Can anyone suggest me how to resolve this...

-Regards

Anil

18 answers

This widget could not be displayed.

This widget could not be displayed.

This widget could not be displayed.

I stuck with this error. How to overcome this...

This widget could not be displayed.

Any update for this..Pls..

This widget could not be displayed.

Hi Anil,

What happens if you run jstack on the stash server, what is your plugin doing that is causing the timeout?

Is it possible to share the source of your plugin?

Charles

This widget could not be displayed.

hi charles,

May I know how to do this "jstack on the stash server".

After downloading the Atlas sdk, I created the plugin and I tried to run with atlas-run. then its giving me the error meesage like I mentitioned in above.

I got struck here..

Can you help here please.

Regards

Anil

This widget could not be displayed.

hi,

any suggestion please. Right now i'm alternately checking on other machine.

This widget could not be displayed.

Any suggestion . pls..

This widget could not be displayed.

Any suggestion . pls..

This widget could not be displayed.

I'm a starter in this stash development. I struck with this error. Any sugestion to overcome this please.

This widget could not be displayed.

Thigs I would try:

1.: Inspect the code for places where it could be
a) waiting for a resource which is not available or
b) stuck in an infinite loop.

2.: Set a breakpoint in the beginning of your plugin's constructor, start the server in debug mode using atlas-debug, attach the debugger and step through the code to see where it gets stuck.

This widget could not be displayed.

Hi,

I'm not using Eclipse IDE / other. I think I cant do the debug properly.. like putting breakpoints..etc.,

I just installed SDK and created a plugin. i.e., Merge check plugin created. This plugin I'm not able to run.

I didn't add any sorce code. I just run the "atlas-run" there it is giving me error message like in which I shared the image.

And I addded some print statements inorder to know whether my created plugin is not responding or not, but its no where given the i client closole or somewhere.

This widget could not be displayed.

Any suggestion please. If the created plugin works fine then only I can able to do my use cases.

Regards,

Anil

This widget could not be displayed.

Hi,

If your plugin does not yet do anything, perhaps you could re-create it?
Also, unless you have a good reason not to, you should use an IDE (Even if you do not want to use debug/breakpoints, it makes your life easier).

This widget could not be displayed.
Hi Balazs Szakmary , I tried to import the created project in eclipse but I failed. Within eclipse once I installed maven related software, and I have given path for apache and I created able to see & set the commandprompt tool. And from here i unable to import the atlassdk's project in my workspace of eclipse. Can you suggest me any link inorder to get the sdk's project in eclipse. Inorder to check for more as per one stash doc I changed the company name in POM.xml and it's getting effected in my stash server's addons. But when I added some print statements in pre repository hook's onResponse(){System.out.println("****")/ hookResponse.out.println("***") then nothing happening in client console or in command prompt editor...earlier It worked smoothly. If I add some wrong syntax or if I missed the import statement after hitting atlas run it shown earlier the compile time error.. but now it's not happenning.. It's showing "Live Enabled". With pluginEnabler problem like in that shared image initially. Regards, Anil
This widget could not be displayed.
Hi Balazs Szakmary , I tried to import the created project in eclipse but I failed. Within eclipse once I installed maven related software, and I have given path for apache and I created able to see & set the commandprompt tool. And from here i unable to import the atlassdk's project in my workspace of eclipse. Can you suggest me any link inorder to get the sdk's project in eclipse. Inorder to check for more as per one stash doc I changed the company name in POM.xml and it's getting effected in my stash server's addons. But when I added some print statements in pre repository hook's onResponse(){System.out.println("****")/ hookResponse.out.println("***") then nothing happening in client console or in command prompt editor...earlier It worked smoothly. If I add some wrong syntax or if I missed the import statement after hitting atlas run it shown earlier the compile time error.. but now it's not happenning.. It's showing "Live Enabled". With pluginEnabler problem like in that shared image initially. Regards Anil
This widget could not be displayed.

Sorry, I cannot help you with Eclipse, I use IDEA. There is a good description here: https://developer.atlassian.com/display/DOCS/Set+up+the+Atlassian+Plugin+SDK+and+Build+a+Project

This widget could not be displayed.

Actually, Though the plugin giving me the error message. I manually uninstalled and installed the target plugin add-ons in stash server then it started working normally.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 21, 2018 in Bitbucket

Branch Management with Bitbucket

As a project manager, I have discovered that different developers want to bring their previous branching method with them when they join the team. Some developers are used to performing individual wo...

1,319 views 8 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you