Local branches not syncing up with remotes.

I have deleted few branches in BitBucket web UI but I still see those branches in my local repo even after pruning branches with no remote.

1 answer

In my experience, if git does an automatic (non-pruning) fetch after you delete remote branches, it modifies the local branches so that they're no longer tracking branches. After that, doing a prune-fetch doesn't effect them.

But in my case I am still seeing the remote branches that I deleted under remotes/origin even for the ones that weren't in my local repo

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jun 12, 2018 in Bitbucket

Do you use any Atlassian products for your personal projects?

After spinning my wheels trying to get organized enough to write a book for National Novel Writing Month (NaNoWriMo) I took my affinity for Atlassian products from my work life and decided to tr...

171 views 20 8
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you