Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,360,435
Community Members
 
Community Events
168
Community Groups

Jira Server repository webhooks disappear

Edited

Hello guys,

I'm experiencing a very strange problem since several months and my patience is slowly running out. I've created a connection between our Jira Server 8.14.1 and our Bitbucket Cloud team and used the created webhooks in a Bitbucket repository to trigger some specific conditions in corresponding Jira Server project. Everything worked fine for months but at some point of time (I think it was in the end of 2020) the both Jira webhooks in Butbucket repository settings suddenly disappeared and the automatic transitions didn't work anymore. Since this point of time I connect Jira to Bitbucket again and again to enable the webhooks and after several days they disappear in Bitbucket (sometimes after 1 day, sometimes after 1 week). Our Jenkins webhook in the same Bitbucket repository don't disappear. Take a look at screenshots attached.

All webhooks are in (Bitbucket repository settings):

Bildschirmfoto 2021-03-22 um 21.35.53.png

Jira webhooks are out after 10 days (same Bitbucket repository settings):

Bildschirmfoto 2021-04-03 um 16.08.54.png

We work on one project only, so I don't know whether it's a global or a single problem in context of one specific repository in Bitbucket.

Did some of you, guys, experienced the same? If yes, how did you fix it? I don't have any clue, because I don't have the ability to take a look in logs of Bitbucket Cloud. Any other ideas? Unfortunately I didn't find any similar problem description on the web.

Best regards
Valdes

1 answer

0 votes

Hi @valdes21 ,

When this issue occurs, is it only the webhooks that disappear, or is the whole integration removed?

I.e., if you check the DVCS accounts page in Jira after the webhooks have disappeared, can you see the Bitbucket Cloud workspace you had previously connected and its repos, or is this missing as well?

I'm just trying to understand the scope of the issue so I can suggest next steps.

Kind regards,
Theodora

Hi @Theodora Boudale ,

Thank you for your response. The integration doesn't disappear, the DVCS page in Jira still show the connected team from Bitbucket. Only the webhooks in the Bitbucket repository are missing.

Kind regards,
Valdes

Today it happened again. What did I do:

  1. Removed the DVCS team integration with Bitbucket in Jira this morning.
  2. Generated a new OAuth key/value pair and created a new Bitbucket integration for Jira. Two webhooks for the repo we work on were created automatically.
  3. Started to implement a new feature this evening. Created a new branch for one of the issues directly over Jira issue. The branch was created successfully and a transition to another state happened (everything good so far).
  4. I finished the implementation after 1 hour, pushed a commit to the origin and created a pull request. Unfortunately no transition happened (but it should according to our workflow and triggers set)!

I checked the repo webhooks in Bitbucket afterwords. The webhooks have disappeared again.

Hi @valdes21 ,

Thank you for the info and I'm sorry for the inconvenience this is causing.

I believe it's best to open a ticket with the support team for this issue. The support team can check logs from our side and access the repo, if needed, in order to investigate this. Since the integration does not get removed, I would suggest opening a ticket with Bitbucket Cloud support team so they can check the logs for any webhooks deletion events initially, and if necessary, they can also work with Jira Server team to troubleshoot this.

I can open the support ticket for you, please feel free to let me know if you'd like me to do that.

If you'd like, you can also open it yourself via https://support.atlassian.com/contact/#/. In "What can we help you with" select "Technical issues and bugs" and then Bitbucket Cloud as product. In the "Give us more details" field, you can copy-paste the URL of this community post, so you won't have to explain the issue again. Please make sure to also mention the URL of the repo where this issue occurs, as this will be needed for the team to check logs. The support ticket will be visible only to you and Atlassian staff, so whatever is posted there won't be publicly visible.

Please feel free to let me know if you have any questions.

Kind regards,
Theodora

Hi @Theodora Boudale ,

Thank you for your recommendation, I've opened a ticket dedicated to this issue.

Best regards
Valdes

Did you get to the bottom of this?
Same thing seems to be happening for me.....

Hi @Paul McGarry ,

Atlassians have found a bug and proposed an update to fix it. After installation of Jira Server 8.18.1 the problem was solved.

Regards
Valdes

Like Theodora Boudale likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Git push size limits are coming to Bitbucket Cloud starting April 4th, 2022

Beginning on April 4th, we will be implementing push limits. This means that your push cannot be completed if it is over 3.5 GB. If you do attempt to complete a push that is over 3.5 GB, it will fail...

3,482 views 3 10
Read article

Atlassian Community Events