Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Implicit grant OAuth results in "Invalid redirect_uri" error

I am integrating Bitbucket with Netlify and Netlify CMS, which uses client side implicit grant to log in and make changes in the repo. 

I have set up an OAuth consumer on Bitbucket and have added the Netlify callback URL [ https://api.netlify.com/auth/done ]and the necessary write access to Account and Repositories.

I then added the resulting Bitbucket OAuth key and secret to Netlify settings. I also did the CMS setup.

Screenshot 2019-07-31 at 10.17.19.png

However, when I then try to log in to the CMS through Bitbucket, I get the error message: 

Invalid redirect_uri
This integration is misconfigured. Contact the vendor for assistance.

Screenshot 2019-07-31 at 09.56.05.png

I saw that on June 5, there was a problem which resulted in this error, but it seems to have been resolved

6 answers

Update: It appears that instead of the Netlify api callback that I entered in the consumer, the redirect_uri parameter in the URL is pointing to my site. 

When I edit the URL parameters manually in the browser to point to the correct callback, things start to work properly.

Any help much appreciated!

Hi Darran

 

Did you ever figure this out? We have exactly same issue, need to somehow set the Callback URL!

 

Thanks

Dave

Like Chan Wan likes this

Hi Darran , I am experiencing the same error , 

have you found a workaround in the configuration to make it work  ?

 

Thanks 

 

marc

I'm experiencing the same error. 

This is my first project using Netlify CMS and Gridsome so it could well be an error on my part. I've started to check my work and came across your post in the research phase.

Im also experiencing this "Invalid redirect_uri" issue when setting up OAuth.

yes, me too

Well only option it seems to switch to GitHub 

I'm having the same problem. It keeps redirecting to localhost. 

Hey all, Netlify CMS maintainer here - can anyone confirm whether this is only happening on localhost?

Hi, for me it happen to both localhost and also netlify.com deployed URL. 

Still happening in Sep 2020 on nellfy.com deployed url. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

256 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you