Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Images not Displaying in Bitbucket Pull Requests in Chrome browser

Whenever I paste a screenshot into a Pull Request, I see a loading" placeholder image that never goes away. It remains there after I save the PR and if I go to another PR and come back. It looks like the image below, with the little file icon in the center flashing like it's loading, but it never goes away. On some PR's I can see the actual images, and for old PR's I can see the actual images, but for most new images I paste into PR's, it looks like this.

Screenshot 2020-11-12 073317.png

At first I thought everyone was not able to see my images, but then I realized it was just me. I typically use Chrome, so I tried in Firefox, and I could see the images fine. So I followed the steps in this link... Tried in incognito mode, disabled all extensions, cleared the browser cache, cookies, service workers, etc. Did these one at a time, closing and re-opening Chrome completely after each. It still didn't work. On a whim, I hit Ctrl+F5. All of a sudden I could see the images. Somehow Chrome seems to have had the "missing image/loading image" image cached and was tying it to new images I was pasting in, even after I completely cleared Chrome's cache, etc. But Ctrl+F5 somehow fixed it.

Posting this question here in case someone has a similar problem in the future. If anyone has any info on why Chrome behaved this way, that would be interesting to know as well.

3 answers

Also have this, but Ctrl-F5 doesn't always resolve it.

I see this daily on my mac... on rare occasions it shows images, but the last month or so it shows images attempting to load (icon flashes) then stops. I am on a mac, so I'm not sure what Ctrl+F5 would do... refreshing the page has no effect.

Going to chrome dev tools, I can see this message under issues and I wonder if it is related:

Content Security Policy of your site blocks some resources because their origin is not included in the content security policy header
it points to this resource:
https://mgas.prod.public.atl-paas.net/v1/event

There are also some Failed to load resource: the server responded with a status of 404. I wonder if you can see the same?

I have also begun seeing this issue in Chrome. The only way for me to temporarily see the images is to clear cached images and files from chrome and re-visit the page, refreshing the page with F5 doesn't work. Then I will be able to see the images, but only until I navigate away from it or refresh the page with F5 then they disappear once again.

+1. This has been happening for the past month, also happening for several teammates. A couple of ctrl+F5 usually fixes it, but pretty random if it takes one or 5 attempts. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Powering DevOps with Bitbucket Server & Data Center

Hi everyone, The Cloud team recently announced 12 new DevOps features that help developers ship better code, faster   ! While we’re all excited about the new improvements to Bitbucket ...

2,570 views 1 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you