Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,481
Community Members
 
Community Events
176
Community Groups

I got error message when I tried to delete a repository in Bitbucket

I'm Admin in Bitbucket, and when I tried to delete a repository I got this error message: An error occurred while processing the request. Check the server logs for more information.

1 answer

0 votes

What do the logs say the problem is?


2022-02-13 17:06:22,740 ERROR [http-nio-7990-exec-533] M.Abuhayah @4GGPEAx1026x77835065x5 ohyzv2 172.25.70.250 "DELETE /users/m.albrahim/repos/test-may HTTP/1.1" c.a.e.i.AsynchronousAbleEventDispatcher There was an exception thrown trying to dispatch event [com.atlassian.bitbucket.event.repository.RepositoryDeletionRequestedEvent[source=com.atlassian.stash.internal.repository.DefaultRepositoryService@5df8c597]] from the invoker [SingleParameterMethodListenerInvoker{method=public void com.atlassian.bitbucket.internal.webhook.WebhookCleanupService.onRepositoryDeleted(com.atlassian.bitbucket.event.repository.RepositoryDeletionRequestedEvent), listener=com.atlassian.bitbucket.internal.webhook.WebhookCleanupService@48736a95} (monitored)]
2022-02-13 17:06:22,757 DEBUG [http-nio-7990-exec-533] M.Abuhayah @4GGPEAx1026x77835065x5 ohyzv2 172.25.70.250 "DELETE /users/m.albrahim/repos/test-may HTTP/1.1" c.a.s.i.e.TransactionAwareEventPublisher Deferring publishing for RepositoryDeletedEvent until AFTER_COMMIT
2022-02-13 17:06:22,759 ERROR [http-nio-7990-exec-533] M.Abuhayah @4GGPEAx1026x77835065x5 ohyzv2 172.25.70.250 "DELETE /users/m.albrahim/repos/test-may HTTP/1.1" c.a.s.i.r.e.DefaultUnhandledExceptionMapperHelper Unhandled exception while processing REST request: "DELETE /users/m.albrahim/repos/test-may HTTP/1.1"

This sort of error happens when you hit the wrong URL for the action.

How were you trying to delete the repository?

From the repository settings 

Bother, I was hoping it was something that would be hitting the wrong URL, but the admin UI (including repository settings) should not be able to do that.

Are there more bits of log in this area that might be relevant?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events