Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

I cannot clone a Bitbucket repository from a Windows based Sourcetree installation. Edited

Hi,

I am using Bitbucket and Sourcetree with a number of students. I found that connecting Sourcetree to Bitbucket on a Mac extremely easy and it worked 100%. Windows however was another story. 

A couple of students ended up getting this ridiculous credential 'helper' with about 12 options, none of which made any sense at all. I've attached an image of a version of this dialog.

I believe the issue is oAuth was perhaps not connected. However everything seemed to be correct: We granted access to Sourcetree, the user was logged on, the remote URL was correct. It would try to clone but just give us a progress bar animation that was clearly doing nothing. Seemingly it created the .git folder but fetched no files. 

There was no real error. It just hung there seemingly cloning OR the credential helper box kept coming up. We tried most if not all the options in the helper dialog, however none of them would have made any sense to any normal person. You might want to look at that from a UX point of view.

I did actually get it working on 2 or 3 windows machines, however the one that got stuck gave us no clue as to what was going on apart from the dialog

Many thanks

 

Pete..Screen Shot 2021-04-29 at 8.54.43 pm.png

1 answer

1 vote

Hi @nexgencodecamp ,

Thank you for the explanation. I do agree Mac and SourceTree, (as I use as well mac and sourcetree). 

Regarding windows I see the next articles quite helpful for your situation

Hi Gonchik,

Thanks for your reply. I took a look at the articles. The first one might be the answer. Either way, we'll have to 'clear out' the existing setup and start again. I think the student may have clicked something inadvertently that stuffed us - neither windows nor sourcetree was good enough to redeem that 'click'

Cheers

 

Pete...

Hi Gonchik,

I tried this today in class with the 2 students concerned. Windows Network Credential Manager was not relevant as there were no windows credentials stored. After banging my proverbial against the wall several times we decided to download Git for Windows and use the command line. 

This worked!

I tried to setup the other student and same issue with Sourcetree: credential manager keeps coming up. The command line worked for him as well.

Others using Windows are fine - just can't fix Sourcetree on these 2 machines. Nevertheless, I found the workaround

Pete...

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS
Community showcase
Published in Bitbucket Pipelines

Bitbucket Pipelines Runners is now in open beta

We are excited to announce the open beta program for self-hosted runners. Bitbucket Pipelines Runners is available to everyone. Please try it and let us know your feedback. If you have any issue...

208 views 4 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you