Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,937
Community Members
 
Community Events
176
Community Groups

How to setup build pipeline for .Net 5.0

Hi everyone,

 

I got a bitbucket repository for a .Net 5.0 project.

The solution contains some .Net 5.0 class library projects and some .Net 5.0 winform projects.

I just want to ask how to setup a build pipeline to esure that all comited code always build?

 

Best regards,

1 answer

1 accepted

Thank you for your answer.

 

I tried the followin scriot but the job failed :

 



# This is a sample build configuration for .NET Core.
# Only use spaces to indent your .yml configuration.
# -----
# You can use any Docker image from Docker Hub, or your own container registry, as your build environment.
image: microsoft/dotnet:sdk:5.0
pipelines:
default:
- step:
script: # Modify the commands below to build your repository.
- export PROJECT_NAME=UpsilonEcosystem.sln
- export TEST_NAME=UpsilonEcosystem.sln
- dotnet restore
- dotnet build $PROJECT_NAME
- dotnet test $TEST_NAME
Like Abir Stolov likes this

What was the error message?

/opt/atlassian/pipelines/agent/build/Upsilon/Common/Forms/Upsilon.Common.Forms.csproj : error NU1201: Project Upsilon.Common.Library is not compatible with net50-windows (.NETFramework,Version=v5.0,Profile=windows). Project Upsilon.Common.Library supports: net50 (.NETFramework,Version=v5.0) [/opt/atlassian/pipelines/agent/build/UpsilonEcosystem.sln]
Like Adrian-Nikola De Ro likes this

Did you find an answer to this error?

This is usually exactly what the error message says, you have to make sure your projects target the same version, in this case either net50-windows or net50, this can probably be changed manually on the csproj files.

I wouldn't change any thing in my project's files because they build successfully on my local machine.

I think the issue is that my solution contains both net50-windows and net50 projects.

I will abandon this, I prefer make my project build in my working machine before commiting.

 

Thank you for your help.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events