Git was not found

Hi,

I found this question https://answers.atlassian.com/questions/55689 which is quite the same as mine, but it seems that we don't have the same context.

I have installed Stash and was working correctly for some months. It is installed on a local machine to make tests before launching it on a real server. I picked option 2 during installation so that my PATH was added the path to Git/cmd.

I went on vacation, during this time no one did anything on the server, and when I came back Stash raised the following error:

------------------

A fatal error has occurred

The following problem occurred which prevents Atlassian Stash from starting correctly:

  • Git was not found on the PATH for Stash. Install Git 1.7.6+, excluding 1.8.4.3, and restart Stash.

------------------

I tried to modify my PATH environment var, tried to uninstall / install again Git, but no way, it doesn't work... I try to type "git --version" in my windows command prompt, and I alsways get "fatal: open /dev/null or dup failed: no such file or directory". I get the same message on Git bash.

So it seems that it is an environment issue, but I can't find out what it is ! Maybe the command prompt is corrupted? Does anyone has already seen that issue ?

Can anyone help or guide me?

Thanks!

Brice

1 answer

0 vote

Sounds like someone HAS done something to your server - they've probably re-installed git or upgraded it and answered 1 or 2 for the installation question.  Or they've messed with the path.

You'll need to locate the correct git.exe on your system and adjust your path so that it is the first one to be included (ideally, I'd bin any others found too)

Thanks Nic for the answer, but I've already tried all that stuff... Trying to launch git.exe from its proper folder, no change... Tested all combinations of paths added to environment PATH... no way... :/

And I'm the only one to connect to that machine, so nobody should have been able to update anything. Also it was during holidays so nobody was in and working on it. I was more thinking about some Windows updates that changed something, or stuff like that...

Well, if you're sure there was no access, a windows update is about the only option. Sadly, because it's Windows and they botch so much, I've got no idea what they could have done to break it!

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

699 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot