Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,653
Community Members
 
Community Events
176
Community Groups

Getting started template for Bitbucket pipeline doesn't show up

The page for getting started with pipeline doesn't appear for my repository. It only appears for a fork repository. 

 

So for this repository I went to Repository settings to enable the pipeline first and what what happens next can be seen on the the screenshots below.

 

pipeline1.PNG

pipeline2.PNG

pipeline3A.PNG

pipeline3.PNG

 I have already tried to disable the pipeline and enable it again, but still the same problem.

 

How can I make the getting started template for pipeline appear again?

 

1 answer

0 votes
Caroline R Atlassian Team Sep 13, 2021

Hi, @Danh Nguyen! Welcome to the community! 

Looks like you are affected by the bug where the Pipeline wizard no longer appears, we are already aware of this and currently tracking this bug at:

Our development team will post an update on the bug report when this is fixed. If you are not familiar with our Bug Request Policy, you can read more about it here

You can add yourself as a watcher (by selecting the Start watching this issue link in the bug report) if you'd like to get notified via email on any updates and also select the This affects my team link to indicate you are affected by this issue. 

As a workaround, you can manually create a bitbucket-peipelines.yml on your main directory and add the following dummy steps to start your first pipeline:

# This is an example Starter pipeline configuration
# Use a skeleton to build, test and deploy using manual and parallel steps
# -----
# You can specify a custom docker image from Docker Hub as your build environment.
image: atlassian/default-image:2

pipelines:
  default:
    - parallel:
      - step:
          name: 'Build and Test'
          script:
            - echo "Your build and test goes here..."

Once created, you can select edit to see the list of the available templates and you can click on any of them, it will automatically remove the old one and replace it with the template.

I hope this helps, but do let me know if you have any questions. 

Kind regards,
Caroline

It took a bit to figure out what you meant here, @Caroline R , but I got it. Thank you for the guidance. 

To aid anyone still trying to figure this out here are the steps:

  • Commit the stub code (e.g what @Caroline R posted, above) to a branch.
  • Go back to the Source view in the Bibucket UI.
  • Find the `bitbucket-pipelines.yml` and click on that.
  • Make sure you are working in the branch you want to, then click the Edit button in the upper right corner of the editor sub window.
  • That will open the file for editing and populate the template selector on the right.
  • Select your preferred template and go from there!

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events