Error while trying to setup Bitbucket Add on

Hi All

 

I am trying to setup a Bitbucket Addon

through Install Add-on Through URL in 'Manage Integrations". Since this is an Add-on under development, this is the preferred way of doing it.

I have baseUrl: setup to top level domain and the oauth url is setup to path "/oauth2".

 

I am not sure why I am getting the following error?

 

https certificates etc. are setup properly.

 

Descriptor baseUrl (https://top.level.domain/) does not begin with the OAuth consumer callback URL (https://top.level.domain/oauth2)

 

If I change the baseUrl to https://top.level.domain/oauth2 - things 'kind of work' :)

But this looks quite "clumsy" any idea why this could be happening?

 

Thanks

 

-abhijit

 

0 answers

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

434 views 6 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you