Error during Clone: Batch response: Authentication required

Hi,

We have error during clone of our repository with LFS enabled

Please could you help us to investiguate?

Thank you.

Error log:

D:\Development\Artwork-Common>git clone ssh://git@bitbucket-artwork:7999/artwork/artwork-common.git .
Cloning into '.'...
remote: Counting objects: 5679, done.
remote: Compressing objects: 100% (5496/5496), done.
remote: Total 5679 (delta 312), reused 4647 (delta 72)
Receiving objects: 100% (5679/5679), 740.42 KiB | 4.87 MiB/s, done.
Resolving deltas: 100% (312/312), done.
Checking out files: 100% (7327/7327), done.
Downloading Artwork/World_Textures/Alphas/Alphas_Brushes/JRO_HSAlphas_Vol02_Jpeg/Jpeg/Connectors/JRO_Connector29_out.jpg (406 KB)
Error downloading object: Artwork/World_Textures/Alphas/Alphas_Brushes/JRO_HSAlphas_Vol02_Jpeg/Jpeg/Connectors/JRO_Connector29_out.jpg (4300932): Smudge error: Error downloading Artwork/World_Textures/Alphas/Alphas_Brushes/JRO_HSAlphas_Vol02_Jpeg/Jpeg/Connectors/JRO_Connector29_out.jpg (430093277586733c554de5e5dcf025f6368661f53a3a82fe06303a2361605a30): batch response: Authentication required: Authorization error: http://bitbucket-artwork:7990/scm/artwork/artwork-common.git/info/lfs/objects/batch
Check that you have proper access to the repository

Errors logged to D:\Development\Artwork-Common\.git\lfs\objects\logs\20180119T134404.4776571.log
Use `git lfs logs last` to view the log.
error: external filter 'git-lfs filter-process' failed
fatal: Artwork/World_Textures/Alphas/Alphas_Brushes/JRO_HSAlphas_Vol02_Jpeg/Jpeg/Connectors/JRO_Connector29_out.jpg: smudge filter lfs failed
warning: Clone succeeded, but checkout failed.
You can inspect what was checked out with 'git status'
and retry the checkout with 'git checkout -f HEAD'

 

Serveur config:

Git 2.14.1

 

Client config:

D:\Development\Artwork-Common>git lfs env
git-lfs/2.3.4 (GitHub; windows amd64; go 1.8.3; git d2f6752f)
git version 2.16.0.windows.2

 

Git Global Config:

[credential]
helper = wincred
[filter "lfs"]
clean = git-lfs clean -- %f
smudge = git-lfs smudge -- %f
process = git-lfs filter-process
required = true

2 answers

This widget could not be displayed.

Hi Simon! Where are you cloning the repo from? Is it from Bitbucket Server? And where are you cloning it to? 

Can you confirm that you have the right permissions to access that repo and that you are using the right credentials to clone it? 

Can you also confirm that you've followed the steps at  Clone Git LFS repository.

Best regards,

Ana

Hi Ana,

Yes, I have right permissions to access Bitbucket. My Git credential are also permanently stored to the Windows Credential Manager.

The authorization error appear during the checkout process.

We don't have the error if we user Git 2.14.1.

But since lfs is deprecated from the clone command, (Git 2.15) the downloading of LFS files from the Bitbucket cause authentication errors on random file.

Regards,

Simon

This widget could not be displayed.

Hi @Simon Lafrance! One of my colleagues informed me that he's already working with you regarding this issue, so we'll continue helping you internally via the Support channel. If you need anything else, let us know!

Have a good day,

Ana

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 21, 2018 in Bitbucket

Branch Management with Bitbucket

As a project manager, I have discovered that different developers want to bring their previous branching method with them when they join the team. Some developers are used to performing individual wo...

1,363 views 9 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you