[Errno 11003] getaddrinfo failed when trying to clone any of our repos from Bitbucket.

I get URLError: [Errno 11003] getaddrinfo failed when trying to clone any of our repos from Bitbucket.

I was thinking it may be a firewall or something else blocking it. Verified Firewall was off, VPN was not running, disabled anti-virus and also white listed bitbucket url in IE.

Any ideas on this error?

1 answer

0 votes
Jason Worley Atlassian Team Aug 21, 2014

Sounds like a web server config issue (apache and/or Tomcat). Does it fail when using both localhost:8080 and 127.0.0.1:8080? What happens when you try it via the command line (SSH)?

Hello Jason,

I  am facing the similar issue.

Winsock function  getaddrinfo fails intermittently with error 11003 [A non-recoverable error occurred during a database lookup] for localhost. This is happening in windows 2012. Could you please let me know the reason why intermittently  fails.

 Regards,

Nirmal.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Thursday in Bitbucket Pipelines

Building a Bitbucket Pipe as a casual coder

...ipe.sh :  #!/bin/bash source "$(dirname "$0")/common.sh" enable_debug extra_args="" if [[ "${DEBUG}" == "true" ]]; then extra_args="--verbose" fi # mandatory variables R...

228 views 0 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you