ECS Deployment error

I am using https://github.com/silinternational/ecs-deploy in my pipeline to do ECS deployment.

 

The build is failing with the error below.

 

An error occurred (ClientException) when calling the DescribeTaskDefinition operation: Unable to describe task definition.

 

When i run the script on my local machine the deployment is successful.

 

Thank you

1 answer

0 votes
MatthewT I'm New Here Dec 08, 2018

I ran into this issue to, it's either a permissions issue ( which is what I thought at first ) or it's a misalignment of the task definitions you are attempting to push to.  In my case I was trying to push a prod task definition to a development cluster and since it couldn't find the "task-prod" on development it failed.  Note that the error is "unable" it's not permission denied.

Hope this helps if someone else lands on this page via google

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

451 views 6 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you