Different version of git on client to server

We are running Stash 3.1.0 and want to upgrade the Git installation on our server to 2.0.5 and keep Git 1.9.4 on our Windows client machines.

Is there any possible problem that could arise from using that combination?

1 answer

2 votes

Hi Ben,

That shouldn't be a problem.

Always make sure that what is installed on the server is listed as supported under the Supported Platforms page.

  • In general, we recommend using the most recent version of Git on both the Stash server and clients, where possible, and subject to the following notes and exceptions.

Best,
Thiago

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 14, 2019 in Bitbucket Pipelines

Building a Bitbucket Pipe as a casual coder

...ipe.sh :  #!/bin/bash source "$(dirname "$0")/common.sh" enable_debug extra_args="" if [[ "${DEBUG}" == "true" ]]; then extra_args="--verbose" fi # mandatory variables R...

274 views 0 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you